Matttermost, Inc.

Push Proxy IOS attach_device 404

Summary

After installing gitlab omnibus, we enabled mattermost, setup our own push proxy server and compile IOS and Android apps. Android app is getting Push notifications without any issue.

IOS App doesn’t get notifications, because the Push Proxy doesn’t send them, because there is no IOS Device registered, and this is because the IOS App is not sending the device id on login, it’s trying to send it afterwards using the attach_device endpoint of the V3 API, but GitlabMattermost seems to be missing this API, since its just returning a 404 not found.

Found this related issue: https://github.com/mattermost/ios/issues/10 His solution was installing mattermost platform from scratch… but this defeats the purpose of taking advantage of the omnibus package…

Any help with this?

Steps to reproduce

  1. Version number
  • Gitlab Omnibus package v9.0
  • Mattermost v3.7.2
  • Mattermost Push Proxy v3.7.1
  • Mattermost IOS app v3.5
  1. Steps to reproduce your issue
  2. Compile IOS app
  3. Setup Push Proxy
  4. Send message from GitlabMattermost to IOS User
  5. Link to the documentation you’re using, noting the step where you encounter the issue.
  • Github readme’s for each app.
  1. The relevant portion of the Mattermost log file at /var/log/gitlab/mattermost/mattermost.log
Error: statusCode=404 data=Optional({"id":"api.context.404.app_error","message":"Sorry, we could not find the page.","detailed_error":"There doesn't appear to be an api call for the url='/api/v3/users/attach_device'.  Typo? are you missing a team_id or user_id as part of the url?","status_code":404})
Failed attaching device id to session
Sorry, we could not find the page.

Hi @icanogbh,

Thanks for your issue report!

I tested on our GitLab instance and push notifications are working fine for me. The only difference is that this instance is on Mattermost v3.8.0. At the moment, we’re looking into fixing the “sign-up with GitLab” option as it’s broken but you can sign up using email/password option.

Mattermost v3.8.0 was released yesterday so GitLab should be upgrading to the new version in a couple of days.

Hope this helps?

Hi Lindy,

Thanks for the follow up, we are currently using the gitlab sign in option, so that might be the issue then… since our IOS developer took a look at the request and we noticed that the username and password need to be sent along in the request.

Thanks for the hint, will be taking a look at it.

Ignacio Canó
Team Lead, Ingeniero de Software

Thanks @icanogbh,

The GitLab login would seem to be the issue then. It should be fixed pretty soon so let us know if your issue is resolved once it’s fixed.

Thanks!

Hi @lindy65,

Just confirmed, the issue is when trying to do a Gitlab SSO, username/password worked.

Guess well have to wait for SSO to be fixed, since Gitlab SSO accounts don’t have a password, so can’t login using username/password in the ios app.

Thanks!

Ignacio Canó
Team Lead, Ingeniero de Software

Hi @icanogbh,

Thanks for your feedback!

Could we have your help seeing if your issue still reproduces with Mattermost 3.8.2? The GitLab sign-in has been fixed.

Let us know how it goes?