Mattermost, Inc.

Push Proxy Configuration

I am attempting to set up the mattermost iOS client for push notifications and I’m running into trouble.

I’ve got the push proxy running on my mattermost server, and I’ve configured it with my certificate and key (looking at the source, it appears I’m supposed to paste in base64 hashes of my push certificate, and my private key). I’m able to do a “GET / HTTP/1.0” on the ReST API, so I know it’s listening.

When I attempt to configure mattermost to talk to it, it fails. I set Send Push Notifications to true, and then paste http://localhost:8066/ into the Push Notification Server field and click Save. If I switch away from the email settings and back, the URL is configured but Send Push Notifications is set back to false.

I’ve tried editing mattermost’s config.json directly to set it to true, but it still seems to not do anything. Any suggestions on what to try next? I don’t see anything in MM’s logs, so I’m out of ideas for debugging.

hi @RangerRick, appreciate the report,

After you update config.json does the System Console UI show true for enabling push notifications, or is it still showing false?

Looks like there is a regression with the System Console in Mattermost v1.3.0 where Email Settings aren’t being saved..