Push Notification Fails "because of missing server Id"


#1

I think I set something up wrong way back in the beginning and I have a baaaaad feeling that it won’t be easy to fix. Push notifications are not working and fail consistently with an error.

Recreation Steps:

  1. User 1 logs off of all instances of Mattermost
  2. User 2 logs into Mattermost and sends a private message to User 1

Actual Results:
Email notification works as expected; however, push notification not received. Log shows error like this:
{“level”:“error”,“ts”:1534026496.377071,“caller”:“app/notification.go:871”,“msg”:“Device push reported as error for UserId=som9ztfzqjyyjg39rb45y9k55y SessionId=hrkg31w54pdcudekr6cddqkmqe message=Failed because of missing server Id”,“user_id”:“som9ztfzqjyyjg39rb45y9k55y”}

Expected Results:
Should be able to receive iOS push notifications

Versions:
./mattermost version
Version: 5.0.0
Build Number: 5.0.0
Build Date: Fri Jun 15 15:17:50 UTC 2018
Build Hash: 85a75526c7c03fca1d14a39cfb3f2638d98d3fe1
Build Enterprise Ready: true
DB Version: 5.0.0

iOS 11
App Version: 1.10.0 (build 127)

Does this mean that I need to downgrade to Team Edition? This page (https://docs.mattermost.com/overview/faq.html#how-does-mattermost-scale-from-teams-to-enterprises) talks about being able to, but I haven’t found any instructions detailing that. Thanks in advance for everyone’s help!


#2

Hi @testerson - Thank you for reaching out!

Does User 1 get push notifications when they are logged in? I believe users need to be logged in to receive push notifications.


#3

Hi,

I got similar error.

Versions:
./mattermost version
Version: 5.1.0
DB Version: 5.1.0

iOS 11
App Version: 1.10.0 (build 127)

{“level”:“error”,“ts”:1534495279.2695405,“caller”:“app/notification.go:879”,“msg”:“Device push reported as error for UserId=dhsmaq1gojgkxm1mwpo5qmr89y SessionId=dah3bzw9d7rnz8cn1t9i7e5kry message=Failed because of missing device Id serverId=41kf54adst8omc8feeiooj5gey”,“user_id”:“dhsmaq1gojgkxm1mwpo5qmr89y”}

However, once the IOS user logout and login again, this issue can’t be found.


#4

Hi @shawn111,

Thank you for reporting this,

Can you help with details on your push notification settings, and can you also help take a look at these troubleshooting docs for any tips: