We're Hiring!

Mattermost, Inc.

Problem with PDF upload

When uploading small PDFs with a few hundred kb that works.

But around 1.2MB i get a 413 response from the server.

Anybody has any idea why that is?

I am running with docker and everything else seems to be working.
the mm-core directory is owned and group 2000.

Which is the ubuntu user on my system.

I raised the limit to 500MB with no result.

EDIT: I found that I can’t upload Plugins either.
I enabled plugin uploads in the settings.

I can install verified Plugins though.

Nothing in the DEBUG logs either.

Hey @prosanhive, thanks for submitting a question on our forum! I’ll do my best to help you out.

If you could clarify a few things that you’re doing so I can better understand.

  1. Where are you seeing the 413 error? - (attach a screenshot & description of what you did to hit it would be great).
  2. How did you go about raising the limit to 500m?
  3. It sounds like you’ve enabled plugins but may not have disabled Require PluginSignature. Can you send the lines in your config.json file under PluginSettings?

Thanks, Looking forward to your reply!

Hi and thanks!

  1. When I attach or drag&drop a file larger than 1.2 megabyte (pinpointed so far).

  2. I went to the system console and set File Storage -> Maximum File Size to: 500.

  3. system console -> Plugin Management -> Require Plugin Signature is set tot false.

I verified the same values are in config.json

Cheers

Thanks! @prosanhive Have you restarted the Mattermost service after making these changes?

I did that now with

docker-compose restart

Unfortunately no Success.

3.system console -> Plugin Management -> Require Plugin Signature is set to false.

Corrected typo.

@prosanhive, can you share what kind of deployment you have along with the server longs? Is this limited to just that single user or more users? Lastly, are you having issues uploading any other kind of file or just PDFs?

Thanks!


services:
  mattermost:
    image: eugenmayer/mattermost-app:team-${VERSION}
    environment:
      MM_USERNAME: ${DB_USER}
      MM_PASSWORD: ${DB_PASSWORD}
      MM_DBNAME: ${DB_NAME}
      MM_SERVICESETTINGS_SITEURL: ${MM_SERVICESETTINGS_SITEURL}
      DB_HOST: db
      DB_PORT_NUMBER: 5432
      # mandatory to fix the mattermost cli https://github.com/mattermost/mattermost-docker/issues/399#issuecomment-508991021
      MM_SQLSETTINGS_DATASOURCE: "postgres://${DB_USER}:${DB_PASSWORD}@db:5432/${DB_NAME}?sslmode=disable&connect_timeout=10"
      VIRTUAL_HOST: ${DOMAINS}
      LETSENCRYPT_HOST: ${DOMAINS}
      LETSENCRYPT_EMAIL: ${LETSENCRYPT_EMAIL}
      SSL:
      SSLCERT: ${MATTERMOST_SSL_CERTIFICATE}
      SSLKEY: ${MATTERMOST_SSL_KEY}
    volumes:
      - /home/ubuntu/docker-volumes/mattermost_data/mm-core/config/:/mattermost/config
      - /home/ubuntu/docker-volumes/mattermost_data/mm-core/data/:/mattermost/data
      - /home/ubuntu/docker-volumes/mattermost_data/mm-core/logs/:/mattermost/logs
      - /home/ubuntu/docker-volumes/mattermost_data/mm-core/plugins/:/mattermost/plugins
      - /home/ubuntu/docker-volumes/mattermost_data/mm-core/client_plugins/:/mattermost/client/plugins
    restart: always

  db:
    image: eugenmayer/mattermost-db:team-${VERSION}
    volumes:
      - /home/ubuntu/docker-volumes/mattermost_data/db:/var/lib/postgresql/data
    environment:
      POSTGRES_DB: ${DB_NAME}
      POSTGRES_USER: ${DB_USER}
      POSTGRES_PASSWORD: ${DB_PASSWORD}
      POSTGRES_ENCODING: "UNICODE"
      POSTGRES_COLLATE: "C"
      POSTGRES_COLLATE_TYPE: "C"
    restart: always

networks:
    default:
       external:
         name: ${NETWORK}
DB_USER=mattermost
DB_PASSWORD=mypassword
DB_NAME=mattermostdb
VERSION=5.26.2
MM_SERVICESETTINGS_SITEURL=https://team.mydomain.com
NETWORK=webproxy
#MM_SQLSETTINGS_DATASOURCE=postgres://${DB_USER}:${DB_PASSWORD}@db:5432/${DB_NAME}?sslmode=disable&connect_timeout=10"


# Your domain (or domains)
DOMAINS=team.mydomain.com

# Your email for Let's Encrypt register
LETSENCRYPT_EMAIL=email@gmail.com

#
# Path to the certificates
# If you use our webproxy should be:
# /home/user/webproxy/data/certs
MATTERMOST_SSL_PATH=/home/ubuntu/nginx-reverse-proxy/nginx-data/certs/team.mydomain.com/certs

I am using git clone https://github.com/evertramos/docker-compose-letsencrypt-nginx-proxy-companion.git for the SSL provisioning.

Email works, basically everything but this works :slight_smile:

All users have the problem. Via web or desktop or mobile Interface. Small files work of any kind. Bigger files not any kind. It seems to differ in filesizes sometimes though.

database log on startup then runs for days without any issues.



Log viewer settings
Auto-refresh logs
Wrap lines
Display timestamps
Fetch
Search
Lines
Actions

      

WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


LOG:  could not open temporary statistics file "pg_stat_tmp/global.tmp": Permission denied


LOG:  could not open temporary statistics file "pg_stat_tmp/global.tmp": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


ERROR:  could not access status of transaction 0


DETAIL:  Could not open file "pg_clog/0000": Permission denied.


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


WARNING:  could not open statistics file "pg_stat_tmp/global.stat": Permission denied


AWS_ACCESS_KEY_ID is required for Wal-E but not set. Skipping Wal-E setup.


AWS_SECRET_ACCESS_KEY is required for Wal-E but not set. Skipping Wal-E setup.


WALE_S3_PREFIX is required for Wal-E but not set. Skipping Wal-E setup.


AWS_REGION is required for Wal-E but not set. Skipping Wal-E setup.


Mattermost logs, nothing pertaining to my tested uploads. 5 different filetypes…all work until the about 1mb mark…1.2 mb is a problem…

Return 413


{"level":"debug","ts":1600360135.0838826,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"GET","url":"/api/v4/users/me/teams/f1pz4twzdpn8jp96116am9us7h/channels/members","request_id":"s1fng3xawjyofx45xa3ztuqjuc","status_code":"200"}


{"level":"error","ts":1600360136.0404055,"caller":"app/notification.go:188","msg":"Skipped sending notification email, address not verified.","user_email":"github@localhost","user_id":"8djcsj46fidz9xnbkh86pxak8a"}


{"level":"debug","ts":1600360136.051258,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"POST","url":"/api/v4/posts","request_id":"ir1uz8mrnpfjieui5eq11ip1sr","status_code":"201"}


{"level":"info","ts":1600360136.054254,"caller":"app/notification_push.go:337","msg":"Notification will be sent","logSource":"notifications","ackId":"zie8osbcpidppffh6n6gx47fka","type":"clear","userId":"axpgchrz67f3xdq7eehwnnjwro","postId":"","status":"Prepared to send"}


{"level":"info","ts":1600360136.177044,"caller":"app/notification_push.go:117","msg":"Notification sent","logSource":"notifications","ackId":"zie8osbcpidppffh6n6gx47fka","type":"clear","userId":"axpgchrz67f3xdq7eehwnnjwro","postId":"","channelId":"ej8493n7cfb1udkjffd31ehama","deviceId":"cItZrVqxTBY:APA91bGVWu1apvLZLcDRN1m83IYOEnDulQdv-MN-aNeA75Fbp8wOamdgBPTkaU0tiXo7vWATyUeTsmbtfyOSO3Bm0bEkZLwoAmEU1UNRE0ZCKeu3zhHD9Cv1dOaI-MpLIk7b1z5Rv6px","status":"Successful"}


{"level":"info","ts":1600360136.878792,"caller":"app/notification_push.go:375","msg":"Notification received","logSource":"notifications","ackId":"zie8osbcpidppffh6n6gx47fka","type":"clear","deviceType":"android","receivedAt":1600360134325,"status":"Received by device"}


{"level":"debug","ts":1600360136.973136,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"POST","url":"/api/v4/notifications/ack","request_id":"t3gjaydg6tf8mpzte1bzkoak9a","status_code":"200"}


{"level":"debug","ts":1600360137.681084,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"POST","url":"/api/v4/channels/members/me/view","request_id":"xteyfdwwf7y59cbz58wn6w3a4h","status_code":"200"}


{"level":"debug","ts":1600360137.9502327,"caller":"wsapi/websocket_handler.go:25","msg":"Websocket request","action":"user_update_active_status"}


{"level":"debug","ts":1600360140.9470284,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"POST","url":"/api/v4/users/status/ids","request_id":"cuboa1bh7ig7txsjxbi5e93t4c","status_code":"200"}


{"level":"debug","ts":1600360155.8026752,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"GET","url":"/","request_id":"pfo19dc9rtn9mjsi8xnkzrbe4a","status_code":"200"}


{"level":"debug","ts":1600360156.0126457,"caller":"app/email_batching.go:110","msg":"Email batching job ran. Some users still have notifications pending.","number_of_users":0}


{"level":"debug","ts":1600360156.6765964,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"POST","url":"/api/v4/files","request_id":"6aquh4n3kpndppgo4srj86j5hy","status_code":"201"}


{"level":"debug","ts":1600360156.789244,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"GET","url":"/api/v4/files/6chbgsu59jgyipjhs1hth3gn8e/thumbnail","request_id":"54tbshtxy7r97mz76ggywf6f4h","status_code":"200"}


{"level":"debug","ts":1600360158.2250826,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"POST","url":"/api/v4/channels/members/me/view","request_id":"e5ktjy8tebg57gn5jimhican5w","status_code":"200"}


{"level":"debug","ts":1600360158.3635557,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"GET","url":"/api/v4/users/me/teams/f1pz4twzdpn8jp96116am9us7h/channels","request_id":"g9woecuxijdzuriutheenj6fcw","status_code":"200"}


{"level":"debug","ts":1600360158.3682544,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"GET","url":"/api/v4/users/me/teams/f1pz4twzdpn8jp96116am9us7h/channels/members","request_id":"fzxzafj1ktnzie3gu7hrp7969y","status_code":"200"}


{"level":"error","ts":1600360159.5990443,"caller":"app/notification.go:188","msg":"Skipped sending notification email, address not verified.","user_email":"github@localhost","user_id":"8djcsj46fidz9xnbkh86pxak8a"}


{"level":"debug","ts":1600360159.614431,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"POST","url":"/api/v4/posts","request_id":"wrk88456bifj9dicor9dxj9c8y","status_code":"201"}


{"level":"info","ts":1600360159.617691,"caller":"app/notification_push.go:337","msg":"Notification will be sent","logSource":"notifications","ackId":"pjros3ph3pya5puzkupezgcnmo","type":"clear","userId":"axpgchrz67f3xdq7eehwnnjwro","postId":"","status":"Prepared to send"}


{"level":"info","ts":1600360159.730923,"caller":"app/notification_push.go:117","msg":"Notification sent","logSource":"notifications","ackId":"pjros3ph3pya5puzkupezgcnmo","type":"clear","userId":"axpgchrz67f3xdq7eehwnnjwro","postId":"","channelId":"ej8493n7cfb1udkjffd31ehama","deviceId":"cItZrVqxTBY:APA91bGVWu1apvLZLcDRN1m83IYOEnDulQdv-MN-aNeA75Fbp8wOamdgBPTkaU0tiXo7vWATyUeTsmbtfyOSO3Bm0bEkZLwoAmEU1UNRE0ZCKeu3zhHD9Cv1dOaI-MpLIk7b1z5Rv6px","status":"Successful"}


{"level":"info","ts":1600360160.7265892,"caller":"app/notification_push.go:375","msg":"Notification received","logSource":"notifications","ackId":"pjros3ph3pya5puzkupezgcnmo","type":"clear","deviceType":"android","receivedAt":1600360157968,"status":"Received by device"}


{"level":"debug","ts":1600360160.8204994,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"POST","url":"/api/v4/notifications/ack","request_id":"7fdo6yep4pn6385xtqbafre6br","status_code":"200"}


{"level":"debug","ts":1600360169.019104,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"POST","url":"/api/v4/channels/members/me/view","request_id":"wg9zyhzkaigfzbjzsdsreyfceo","status_code":"200"}


{"level":"debug","ts":1600360171.2413762,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"POST","url":"/api/v4/users/status/ids","request_id":"qwm8cyr4i3fj3mesap357oi5do","status_code":"200"}


{"level":"debug","ts":1600360185.9645278,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"GET","url":"/","request_id":"mj1zhoepgj8jz8pduh89rde5to","status_code":"200"}


{"level":"debug","ts":1600360186.0124605,"caller":"app/email_batching.go:110","msg":"Email batching job ran. Some users still have notifications pending.","number_of_users":0}


{"level":"debug","ts":1600360198.106569,"caller":"wsapi/websocket_handler.go:25","msg":"Websocket request","action":"user_update_active_status"}


{"level":"debug","ts":1600360200.963005,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"POST","url":"/api/v4/users/status/ids","request_id":"omp7bn8usjrb3p7chsyr3cooho","status_code":"200"}


{"level":"debug","ts":1600360216.012529,"caller":"app/email_batching.go:110","msg":"Email batching job ran. Some users still have notifications pending.","number_of_users":0}


{"level":"debug","ts":1600360216.1126838,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"GET","url":"/","request_id":"z6chbg67rf8h8r17cuf1emdnhc","status_code":"200"}


{"level":"debug","ts":1600360231.2618015,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"POST","url":"/api/v4/users/status/ids","request_id":"ssr3k169sjfzxkiso85jhh81pr","status_code":"200"}


{"level":"debug","ts":1600360246.0125544,"caller":"app/email_batching.go:110","msg":"Email batching job ran. Some users still have notifications pending.","number_of_users":0}


{"level":"debug","ts":1600360246.2631724,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"GET","url":"/","request_id":"94jb8ueg3fya9c7dof3ecs9mfr","status_code":"200"}


{"level":"debug","ts":1600360258.3105075,"caller":"wsapi/websocket_handler.go:25","msg":"Websocket request","action":"user_update_active_status"}


{"level":"debug","ts":1600360260.9595742,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"POST","url":"/api/v4/users/status/ids","request_id":"4eff13p3qffg9nc4shg5ec1ore","status_code":"200"}


{"level":"debug","ts":1600360272.8073142,"caller":"app/web_conn.go:419","msg":"websocket.read: closing websocket","user_id":"axpgchrz67f3xdq7eehwnnjwro","error":"websocket: close 1006 (abnormal closure): unexpected EOF"}


{"level":"debug","ts":1600360272.808103,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"GET","url":"/api/v4/websocket","request_id":"7gjqj7eo9jgf8fw3ttjdy651ic"}


{"level":"debug","ts":1600360276.012734,"caller":"app/email_batching.go:110","msg":"Email batching job ran. Some users still have notifications pending.","number_of_users":0}


{"level":"debug","ts":1600360276.4116495,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"GET","url":"/","request_id":"hhiyd4hb83b73p47sc8kf3dp7r","status_code":"200"}


{"level":"debug","ts":1600360291.2402627,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"POST","url":"/api/v4/users/status/ids","request_id":"mtgzguiobbddbxk7yz63jfqpjr","status_code":"200"}


{"level":"debug","ts":1600360306.0125265,"caller":"app/email_batching.go:110","msg":"Email batching job ran. Some users still have notifications pending.","number_of_users":0}


{"level":"debug","ts":1600360306.5748878,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"GET","url":"/","request_id":"sqem9nqhytgiz853jbt7h8y7xe","status_code":"200"}


{"level":"debug","ts":1600360314.8928592,"caller":"wsapi/websocket_handler.go:25","msg":"Websocket request","action":"user_update_active_status"}


{"level":"debug","ts":1600360318.469034,"caller":"wsapi/websocket_handler.go:25","msg":"Websocket request","action":"user_update_active_status"}


{"level":"debug","ts":1600360320.9578261,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"POST","url":"/api/v4/users/status/ids","request_id":"x9t1u3me3brybmeoye41yqfrqe","status_code":"200"}


{"level":"debug","ts":1600360323.8577852,"caller":"app/web_conn.go:419","msg":"websocket.read: closing websocket","user_id":"efzn5b4aapny8g1swifzg9bkke","error":"websocket: close 1006 (abnormal closure): unexpected EOF"}


{"level":"debug","ts":1600360323.8581703,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"GET","url":"/api/v4/websocket","request_id":"jyp3gdqq6pnh9j7td6dphrjjde"}


{"level":"debug","ts":1600360327.2729628,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"GET","url":"/api/v4/channels/5xex9ec6z7f99pzqzeu3iqrj5c/posts","request_id":"bkxr69ox57nxdyxywrww9734mw","status_code":"200"}


{"level":"debug","ts":1600360327.2811027,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"POST","url":"/api/v4/users/ids","request_id":"tpxxdqkzytg68efjk73h58njnw","status_code":"200"}


{"level":"debug","ts":1600360327.5207732,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"GET","url":"/api/v4/channels/wqts3gdcrfn33cbst55x8mucua/posts","request_id":"dd39q9emcid65ja4ryt77twa6r","status_code":"200"}


{"level":"debug","ts":1600360336.012539,"caller":"app/email_batching.go:110","msg":"Email batching job ran. Some users still have notifications pending.","number_of_users":0}


{"level":"debug","ts":1600360336.7314663,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"GET","url":"/","request_id":"meeojc7agpg65pzua6nofcz47e","status_code":"200"}


{"level":"debug","ts":1600360351.2384076,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"POST","url":"/api/v4/users/status/ids","request_id":"7dhfp4t6ytg7xrzyc4nzbytrar","status_code":"200"}


{"level":"debug","ts":1600360366.012781,"caller":"app/email_batching.go:110","msg":"Email batching job ran. Some users still have notifications pending.","number_of_users":0}


{"level":"debug","ts":1600360366.862495,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"GET","url":"/","request_id":"pmdwswqysirhjnrmwk5j3r6iwo","status_code":"200"}


{"level":"debug","ts":1600360375.3084533,"caller":"wsapi/websocket_handler.go:25","msg":"Websocket request","action":"user_update_active_status"}


{"level":"debug","ts":1600360378.678811,"caller":"wsapi/websocket_handler.go:25","msg":"Websocket request","action":"user_update_active_status"}


{"level":"debug","ts":1600360380.9575915,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"POST","url":"/api/v4/users/status/ids","request_id":"5ajurna5bbf45yg18pt3mjp8aw","status_code":"200"}


{"level":"debug","ts":1600360396.0125756,"caller":"app/email_batching.go:110","msg":"Email batching job ran. Some users still have notifications pending.","number_of_users":0}


{"level":"debug","ts":1600360397.0424707,"caller":"web/handlers.go:100","msg":"Received HTTP request","method":"GET","url":"/","request_id":"zshh3uqqmi84fco17qinats9sy","status_code":"200"}

@prosanhive. Thanks for uploading this information! Based on what I have, it looks like this is something wrong with the Nginx max upload size config. I see you mentioned that you’ve already upped the config to 500m. How did you increase this?

Max upload size is controlled by both Nginx and PHP. So, there is a chance it’s set in one place and not the other.

If you could do the below and verify the config as you go, please.

  1. Open /etc/nginx/nginx.conf to and search for the line client_max_body_size. If this does not exist, add the below, if this does exist and is not commented out modify it to 50M. Save then exit.
  2. Restart the nginx server with sudo systemctl restart nginx

Now we need to check and modify the php.ini config:
Open your php.ini file and do a search for the below three lines.

;This sets the maximum amount of memory in bytes that a script is allowed to allocate
memory_limit = 32M

;The maximum size of an uploaded file.
upload_max_filesize = 2M

;Sets max size of post data allowed. This setting also affects file upload. To upload large files, this value must be larger than upload_max_filesize
post_max_size = 3M;This sets the maximum amount of memory in bytes that a script is allowed to allocate
memory_limit = 32M

;The maximum size of an uploaded file.
upload_max_filesize = 2M

;Sets max size of post data allowed. This setting also affects file upload. To upload large files, this value must be larger than upload_max_filesize
post_max_size = 3M

Here you can increase the file size to something that matches what you’re looking for. I’d go with 50M or more.

Now you’ll want to restart your php instance. sudo systemctl restart php-fpm should do the trick.

This should resolve the problem. If you notice anything strange during this process or the max file sizes are not what you’d expect, please copy the config line and paste it here to see.

Thanks!

Thank you. You helped me search at the right spot.

With the dockerized reverse proxy I had to add

USE_NGINX_CONF_FILES=true

to my .env to make it use my nginx.conf.

Now it worked! Cheers