Mattermost, Inc.

Problem with installation

I’m trying to install Mattermost 4.10.0. Service start properly and it’s available via web browser, but when I create first user and log in, I get information:

No teams are available to join. Please create a new team or ask your administrator for an invite.

and there is no option to do anything. Can you help me?

Hi @mjaqb,

normally the first user you are creating is automatically an admin and can create additional teams.

If that somehow fails you can still make your user admin with the mattermost/platform binary from the console (it can also be used to create teams).

Thanks for suggestion. When I try to create team from command line I get message:

Error: Team creation failed: Team.IsValid: This URL is unavailable. Please try another., id=gdist9np47gbi8ynp7azgygk8r

What can be wrong? I try to set different names.

Can you post the exact command you have tried?

./mattermost team create --name admin --display_name “Admin Team”

Ah, you have already upgraded to 5.0 by now?

Interesting it seems this command always fails if the word “admin” is part of the name of the team (could reproduce it here as well with 5.0.1). @amy.blais something worth looking into from development?

Unfortunetly - I was trying also with other team names - with the same effect. I don’t try to upgrade to 5.0 because I have install it on the QNAP NAS and 4.10 is the newest package and I don’t want to install from source. Previously I use version 3 without problems.

That is strange, especially since the executable was only renamed to Mattermost in 5.0.

Can you post the other commands you tried to execute?

Apologies for late reply - @mjaqb please take a look at fbartels’ questions above and let me know if you need any help!

I try to execute
./mattermost team create --name test --display_name “Test Team”
(mattermost is symbolic link to “platform”), command:
./platform team create --name test --display_name “Test Team”
gives the same effect.

Now I get log:
{“level”:“info”,“ts”:1531954743.436568,“caller”:“utils/i18n.go:83”,“msg”:“Loaded system translations for ‘en’ from ‘/share/CACHEDEV1_DATA/.qpkg/Mattermost/i18n/en.json’”}
{“level”:“info”,“ts”:1531954743.4694352,“caller”:“app/app.go:181”,“msg”:“Server is initializing…”}
{“level”:“info”,“ts”:1531954743.4822884,“caller”:“sqlstore/supplier.go:198”,“msg”:“Pinging SQL master database”}
{“level”:“info”,“ts”:1531954744.2110717,“caller”:“app/license.go:44”,“msg”:“License key from https://mattermost.com required to unlock enterprise features.”}
{“level”:“info”,“ts”:1531954744.3533795,“caller”:“app/app.go:225”,“msg”:“Stopping Server…”}
{“level”:“info”,“ts”:1531954744.3534963,“caller”:“app/web_hub.go:112”,“msg”:“stopping websocket hub connections”}
{“level”:“warn”,“ts”:1531954744.353545,“caller”:“app/web_hub.go:117”,“msg”:“We appear to have already sent the stop checking for deadlocks command”}
{“level”:“info”,“ts”:1531954744.353612,“caller”:“sqlstore/supplier.go:761”,“msg”:“Closing SqlStore”}
{“level”:“info”,“ts”:1531954744.3538537,“caller”:“app/app.go:245”,“msg”:“Server stopped”}

but it still show me that there is no teams available to join.

Team creation seems to succeed, though. Do you see the team when calling ./platform team list?

This sounds an awful lot like your mattermost is configured very strictly. e.g. https://docs.mattermost.com/administration/config-settings.html?highlight=enableteamcreation#enable-team-creation is set.

You can also add members to a team from the commandline with ./platform team add $MMTeamname $MMLogin

Who is maintaining the QNAP image for Mattermost? Don’t they provide documentation for their app?

Do you see the team when calling ./platform team list?

Unfortunetly - no - output is:

./platform team list

{“level”:“info”,“ts”:1532109274.1266804,“caller”:“utils/i18n.go:83”,“msg”:“Loaded system translations for ‘en’ from ‘/share/CACHEDEV1_DATA/.qpkg/Mattermost/i18n/en.json’”}
{“level”:“info”,“ts”:1532109274.127424,“caller”:“app/app.go:181”,“msg”:“Server is initializing…”}
{“level”:“info”,“ts”:1532109274.133929,“caller”:“sqlstore/supplier.go:198”,“msg”:“Pinging SQL master database”}
{“level”:“info”,“ts”:1532109274.204576,“caller”:“app/license.go:44”,“msg”:“License key from https://mattermost.com required to unlock enterprise features.”}
test
{“level”:“info”,“ts”:1532109274.2060509,“caller”:“app/app.go:225”,“msg”:“Stopping Server…”}
{“level”:“info”,“ts”:1532109274.2061427,“caller”:“app/web_hub.go:112”,“msg”:“stopping websocket hub connections”}
{“level”:“warn”,“ts”:1532109274.2061777,“caller”:“app/web_hub.go:117”,“msg”:“We appear to have already sent the stop checking for deadlocks command”}
{“level”:“info”,“ts”:1532109274.206228,“caller”:“sqlstore/supplier.go:761”,“msg”:“Closing SqlStore”}
{“level”:“info”,“ts”:1532109274.2064068,“caller”:“app/app.go:245”,“msg”:“Server stopped”}

This sounds an awful lot like your mattermost is configured very strictly. e.g.

This option is set to “true”.

You can also add members to a team from the commandline with ./platform team add $MMTeamname $MMLogin

I have tried, but it still don’t works. Output is:

./platform team add test test

{“level”:“info”,“ts”:1532109261.5454526,“caller”:“utils/i18n.go:83”,“msg”:“Loaded system translations for ‘en’ from ‘/share/CACHEDEV1_DATA/.qpkg/Mattermost/i18n/en.json’”}
{“level”:“info”,“ts”:1532109261.5461566,“caller”:“app/app.go:181”,“msg”:“Server is initializing…”}
{“level”:“info”,“ts”:1532109261.5585523,“caller”:“sqlstore/supplier.go:198”,“msg”:“Pinging SQL master database”}
{“level”:“info”,“ts”:1532109261.748923,“caller”:“app/license.go:44”,“msg”:“License key from https://mattermost.com required to unlock enterprise features.”}
{“level”:“info”,“ts”:1532109262.1212337,“caller”:“sqlstore/post_store.go:1243”,“msg”:“Post.Message supports at most 16383 characters (65535 bytes)”}
{“level”:“info”,“ts”:1532109262.2157805,“caller”:“app/app.go:225”,“msg”:“Stopping Server…”}
{“level”:“info”,“ts”:1532109262.215876,“caller”:“app/web_hub.go:112”,“msg”:“stopping websocket hub connections”}
{“level”:“warn”,“ts”:1532109262.215911,“caller”:“app/web_hub.go:117”,“msg”:“We appear to have already sent the stop checking for deadlocks command”}
{“level”:“info”,“ts”:1532109262.2159512,“caller”:“sqlstore/supplier.go:761”,“msg”:“Closing SqlStore”}
{“level”:“info”,“ts”:1532109262.2162085,“caller”:“app/app.go:245”,“msg”:“Server stopped”}

Meaby it will be easier to take some default config file and use it?

it is a bit hidden, but your test team is right there:

year team add command also looks fine to me. you still have that team selection screen when logging in?

Unfortunetely - yes.

Then I am unfortunately out of ideas.

OK - now it was my mistake. I have refreshed page and nothing happened, but when I logoff and login back - now it’s work. But still - I don’t have any admin options (I try to ./platform roles system_admin test) - so I can’t setup email notifications etc. Also I can’t create new channels (what is interesting it is possible from mobile app), private channels etc. Is there any way to check this - command line is not most friendly option :wink:

Hi @mjaqb!

Would one of these sections in our docs help:
https://docs.mattermost.com/install/troubleshooting.html#lost-system-administrator-account
https://docs.mattermost.com/install/troubleshooting.html#locked-out-of-system-administrator-account

Let me know if these didn’t help resolve the issue.