Mattermost, Inc.

Problem setting development enviroment on ubuntu

I am trying to set a development environment for Mattermost on Ubuntu.

I have used the following guides:
Installing Developer Components on Ubuntu 16.04
https://docs.mattermost.com/developer
and
Compiling Mattermost v3.8.2
https://docs.mattermost.com/developer/dev-setup-compiling.html

When running “make run” the build process compiles the front-end files and stuck with the following message:

           images/favicon/redfavicon-16x16.png    18.5 kB          [emitted]         
                           images/appIcons.png    10.1 kB          [emitted]         

[41] ./stores/redux_store.jsx 1.73 kB {60} [built]
[49] ./actions/user_actions.jsx 29.8 kB {60} [built]
[76] ./~/react-redux/es/index.js 293 bytes {60} [built]
[77] ./~/mattermost-redux/actions/channels.js 69.2 kB {60} [built]
[88] ./~/babel-runtime/core-js/json/stringify.js 194 bytes {60} [built]
[201] ./~/mattermost-redux/actions/general.js 9.82 kB {60} [built]
[212] ./actions/websocket_actions.jsx 16.8 kB {60} [built]
[214] ./i18n/i18n.jsx 6.32 kB {60} [built]
[689] ./root.jsx 5.9 kB {60} [built]
[690] ./root.html 4.33 kB {60} [built]
[691] ./~/babel-polyfill/lib/index.js 932 bytes {60} [built]
[692] ./~/whatwg-fetch/fetch.js 12.8 kB {60} [built]
[1327] ./~/babel-polyfill/~/core-js/shim.js 7.48 kB {60} [built]
[1704] ./~/perfect-scrollbar/jquery.js 167 bytes {60} [built]
[2040] multi babel-polyfill whatwg-fetch ./root.jsx root.html 64 bytes {60} [built]

  • 2600 hidden modules
    Child html-webpack-plugin for “root.html”:
    [0] ./config/manifest.json 89 bytes {0} [built]
    [1] ./images/favicon/android-chrome-192x192.png 88 bytes {0} [built]
    [2] ./images/favicon/apple-touch-icon-120x120.png 88 bytes {0} [built]
    [3] ./images/favicon/apple-touch-icon-144x144.png 88 bytes {0} [built]
    [4] ./images/favicon/apple-touch-icon-152x152.png 88 bytes {0} [built]
    [5] ./images/favicon/apple-touch-icon-57x57.png 88 bytes {0} [built]
    [6] ./images/favicon/apple-touch-icon-60x60.png 88 bytes {0} [built]
    [7] ./images/favicon/apple-touch-icon-72x72.png 88 bytes {0} [built]
    [8] ./images/favicon/apple-touch-icon-76x76.png 88 bytes {0} [built]
    [9] ./images/favicon/favicon-16x16.png 88 bytes {0} [built]
    [10] ./images/favicon/favicon-32x32.png 88 bytes {0} [built]
    [11] ./images/favicon/favicon-96x96.png 88 bytes {0} [built]
    [12] ./~/html-webpack-plugin/lib/loader.js!./root.html 4.33 kB {0} [built]

And yet, Mattermost is not available on http://localhost:8065

I have tested it with Ubuntu 14.04 and 16.04.02 with Mattermost 3.8.2 and 3.9.0.

Any idea how to fix this issue?
Is there a way to write more information to logs?

Thank you

UPDATE
It seems that when using “he” codepage, “make run” command and “make run-server” commands are not working properly. Changing “he” to “en” solved the problem.

Another issue. It seems that “make build-linux” returns:
Makefile:319: recipe for target ‘build-linux’ failed
make: *** [build-linux] Error 2

full log:
ub@ub-VirtualBox:~/go/src/github.com/mattermost/platform$ make build-linux
Preparation for running go code
go get github.com/Masterminds/glide
touch .prebuild
Build Linux amd64
env GOOS=linux GOARCH=amd64 go install -ldflags “-X github.com/mattermost/platform/model.BuildNumber=dev -X ‘github.com/mattermost/platform/model.BuildDate=ג’ מאי 16 11:09:27 UTC 2017’ -X github.com/mattermost/platform/model.BuildHash=0a20e8d3269515e2d44a0bcad0a2408f62245814 -X github.com/mattermost/platform/model.BuildHashEnterprise=none -X github.com/mattermost/platform/model.BuildEnterpriseReady=false” ./cmd/platform
# github.com/mattermost/platform/cmd/platform
usage: link [options] main.o
-B note
add an ELF NT_GNU_BUILD_ID note when using ELF
-D address
set data segment address (default -1)
-E entry
set entry symbol name
-H type
set header type
-I linker
use linker as ELF dynamic linker
-L directory
add specified directory to library path
-R quantum
set address rounding quantum (default -1)
-T address
set text segment address (default -1)
-V print version and exit
-X definition
add string value definition of the form importpath.name=value
-a disassemble output
-buildid id
record id as Go toolchain build id
-buildmode mode
set build mode
-c dump call graph
-cpuprofile file
write cpu profile to file
-d disable dynamic executable
-debugtramp int
debug trampolines
-dumpdep
dump symbol dependency graph
-extar string
archive program for buildmode=c-archive
-extld linker
use linker when linking in external mode
-extldflags flags
pass flags to external linker
-f ignore version mismatch
-g disable go package data checks
-h halt on error
-installsuffix suffix
set package directory suffix
-k symbol
set field tracking symbol
-libgcc string
compiler support lib for internal linking; use “none” to disable
-linkmode mode
set link mode
-linkshared
link against installed Go shared libraries
-memprofile file
write memory profile to file
-memprofilerate rate
set runtime.MemProfileRate to rate
-msan
enable MSan interface
-n dump symbol table
-o file
write output to file
-pluginpath string
full path name for plugin
-r path
set the ELF dynamic linker search path to dir1:dir2:…
-race
enable race detector
-s disable symbol table
-tmpdir directory
use directory for temporary files
-u reject unsafe packages
-v print link trace
-w disable DWARF generation
Makefile:319: recipe for target ‘build-linux’ failed
make: *** [build-linux] Error 2

Hi @JH635,

Thanks for your issue report! I’ll ask one of our devs to take a look and post feedback here for you.

I’m not sure whether upgrading to the latest version would help solve your issue, but just letting you know that v3.9.0 shipped on May 16th.

Thank you lindy65.
The issue reproduced also on the latest (3.9.0) version.

Thanks @JH635,

If you want to set up a developer environment, you should use make run, and if you want to make a binary, then the correct command is make package.

It sounds like make run was successful in the end? If not, these tips might help: https://docs.mattermost.com/developer/dev-setup-troubleshooting.html#other-errors