Mattermost, Inc.

Private SMTP email is not working in v4.5.0

Email Setting in my config file

“EmailSettings”: {
“EnableSignUpWithEmail”: true,
“EnableSignInWithEmail”: true,
“EnableSignInWithUsername”: true,
“SendEmailNotifications”: true,
“UseChannelInEmailNotifications”: false,
“RequireEmailVerification”: false,
“FeedbackName”: “Chat”,
“FeedbackEmail”: "chat@xxx.com",
“FeedbackOrganization”: “”,
“EnableSMTPAuth”: true,
“SMTPUsername”: "chat@xxx.com",
“SMTPPassword”: “XXX”,
“SMTPServer”: “mail.xxx.com”,
“SMTPPort”: “465”,
“ConnectionSecurity”: “TLS”,
“InviteSalt”: “rpq3jonwwtx1jqnoxernzcnnwedpnjt6”,
“SendPushNotifications”: false,
“PushNotificationServer”: “”,
“PushNotificationContents”: “generic”,
“EnableEmailBatching”: false,
“EmailBatchingBufferSize”: 256,
“EmailBatchingInterval”: 30,
“SkipServerCertificateVerification”: false,
“EmailNotificationContentsType”: “full”
}

Hi @sathyadurai,

Thanks for your feedback,

Could you share which version of Mattermost you have installed as well as a little about your environment?

Matter Most Version - v4.5.0
Installed in CentOs

Hi @sathyadurai,

Thanks for your feedback,

Here is the documentation that you’ll need to set up your email.

I already tried this way.

I am getting error like “Connection unsuccessful: Failed to open TLS connection”

That error message means that Mattermost couldn’t connect to your email server. Can you ping the SMTPServer from the system that you’ve installed Mattermost on? Have you verified that your SMTPUsername, SMTPPassword, SMTPPort, and ConnectionSecurity parameters are correct by successfully using them in some other email-enabled application?

1 Like