We're Hiring!

Mattermost, Inc.

Plugin activation error

I can activate my plugin on my local docker in preview mode but not on the company server.
Any advice?:slight_smile:

I do pretty much the same as in: Quick Start

Error:

{"level":"error","ts":1621582705.1999743,"caller":"mlog/log.go:232","msg":"Unable to activate plugin","plugin_id":"com.mattermost.server-weather","error":"unable to start plugin: com.mattermost.server-weather: Unrecognized remote plugin message: \n\nThis usually means that the plugin is either invalid or simply\nneeds to be recompiled to support the latest protocol.","errorVerbose":"Unrecognized remote plugin message: \n\nThis usually means that the plugin is either invalid or simply\nneeds to be recompiled to support the latest protocol.\nunable to start plugin: com.mattermost.server-weather\ngithub.com/mattermost/mattermost-server/v5/plugin.(*Environment).Activate\n\tgithub.com/mattermost/mattermost-server/v5/plugin/environment.go:268\ngithub.com/mattermost/mattermost-server/v5/app.(*App).SyncPluginsActiveState.func2\n\tgithub.com/mattermost/mattermost-server/v5/app/plugin.go:132\nruntime.goexit\n\truntime/asm_amd64.s:1374"}

Where are you loading the plugin from/installing it from?

1 Like

I bundle the files into a tar file and then upload/enable it via the system console ui.
is that what you mean?

Yes, and sorry for the delayed response. Is it at all possible for you to share a copy of the plugin with me so I can test it myself? Thanks!