Mattermost Peer-to-Peer Forum

Omnibus gitlab mattermost server update 5.3 to 5.5 fail


#1

For troubleshooting questions, please post in the following format:

Summary

Upgrade steps are confusing in documentation, and don’t work. Omnibus chef cookbooks seem to overwrite manual changes to mattermost install directory

Steps to reproduce

Gitlab 11.4.6 Mattermost 5.3.1
Follow upgrade instructions https://docs.mattermost.com/administration/upgrade.html

Expected behavior

Mattermost is upgraded to 5.5 after above steps

Observed behavior

Mattermost remains at version 5.3.1

Is there an easier omnibus mechanism to upgrade mattermost? or is there expectations that a near future release of omnibus gitlab will include mattermost 5.5? 5.3.1 currently is not importing slack data and we need this feature asap.


#2

Hi @oscargoldman,

I believe Gitlab is currently using Mattermost v5.4: https://docs.gitlab.com/omnibus/gitlab-mattermost/#upgrading-gitlab-mattermost. Mattermost v5.5 for Gitlab will be available in their next release.


#3

hmmm, we just upgraded our gitlab install to 11.4.6 and mattermost is still indicating it’s 5.3.1. Any idea why it wouldn’t have upgraded to 5.4 at least?


Virus-free. www.avg.com


#4

Hi @oscargoldman,

Gitlab 11.4 is compatible with Mattermost v5.3, so you would need to upgrade to Gitlab 11.5 to be able to get Mattermost v5.4. The chart in this link shows which Gitlab version is compatible with which Mattermost version: https://docs.gitlab.com/omnibus/gitlab-mattermost/#upgrading-gitlab-mattermost.


#5

Ah I see - looks like gitlab 11.5 will be out shortly so hopefully it contains mattermost 5.4 with some slack import fixes.


#6

@oscargoldman, Sorry about that, I thought 11.5 was already released. I believe it will be released in the next few days (usually their release day is around the 22nd of each month).