We're Hiring!

Mattermost, Inc.

Not all persons inside a channel are shown anymore

Summary

with the ‘@’ sign not all persons that are part of the channel are shown anymore

Steps to reproduce

v 5.33.3
just enter the @ in different channels and with different browsers and logins.

Expected behavior

that always all person of the channel are shown when just the @ is entered

Observed behavior

depending on the channel and also on the web browser and login a different number of names are shown when just the @ sign is entered

this is what another user of our instance does see in the channel when entering the @, so no names of persons at all.
grafik

this is what I (as an admin) do see in this channel when entering the @, so a list with a scroll bar since the channel has 28 persons and I do see all 28 names.

grafik

But in other channels even myself as an admin do not see any names. And only three additional names which are not part of the channel are shown.
grafik

and this is what I do see with a test login and in another browser, so only 3 of the 28 persons of the channel.
grafik

Can I ask if your Mattermost logs are showing any errors, and if your Apache/Nginx error.log files contain any information pertaining to this?

the log files do not show anything special.
We are running Mattermost in a docker-compose installation together with several other docker-compose containers for other systems on an Ubuntu root server with a nginx/letsencrypt docker-compose installation in front of all these containers.

What I just noticed, when I enter a channel and do type the @ then only the “here, channel and all” are shown.
When I then go in the upper menu and do click on manage members for this channel and afterwards type in the @ all names of the persons inside that channel are shown correctly inside the popup.
Switching the channel and going back to the channel do still show the names when the @ is entered as long as the broswers cache is not cleared.

closing the browser and clearing its cache and then reopening the browser and going to the channel does again only show the “here, channel and all” when the @ is entered.
Going again on “manage member” and afterwards typing again the @ all names do again popup.
So at least this is a workaround I can communicate to our users.
I checked it also with my test account for non admin users that this workaround does work.
Tested on Windows10 (20H2) 64bit with latest updates and with Firefox v88 (88.0b8 beta) and Edge Chromium. Same behavior in both browsers.

I can confirm experiencing both the issue as GuidoD has described it, as well as the workaround, post update to 5.33.3.

1 Like

I opened a ticket to take a look: [MM-34738] Not all persons inside a channel are shown anymore - Mattermost

2 Likes

@GuidoD, can you check via the developer console the HTTP request being made when typing that @? The frontend should hit /api/v4/users/autocomplete and get up to 25 users returned:

If that response is empty when you get no mentions, it helps pinpoint the issue server-side. Do you use ElasticSearch and have Enable Elasticsearch for autocomplete queries enabled? (Or Bleve, and use the same?)

If the response contains entries that then don’t show up client-side, it helps pinpoint the issue client-side. Do you see any console errors at that point?

Hello @GuidoD - Thanks for raising this issue. Would you be able to provide us with the additional info Jesse asked for above?

In specific I need:

  • The response that you are getting from the /api/v4/users/autocomplete request when you are NOT seeing all users. If you can show us the request being made, and the complete response you are getting, it will be really helpful.
  • Server logs in DEBUG mode during the time when this autocomplete request is being made.
  • Do you have Elasticsearch enabled along with EnableAutocomplete set to true?
  • Or do you have Bleve enabled along with EnableAutocomplete set to true?
  • Do you also see any console errors in the browser?
1 Like

sorry that I had not responded earlier. I had to solve a lot of other system problems and this here had a workaround, therefore this topic had been on a low priority on my side.

At least in the current 5.35.0 release I do no longer have the problem.
And yes we do have the bleve enabled with EnableAutocomplete set to true.
Perhaps it was a problem in the index. I did recreate the index for bleve a couple of days ago.
But I had not checked at that time if the problem had been gone.
I only checked it now and noticed that the problem does no longer exist.

Thank you for the confirmation @GuidoD !