Mattermost, Inc.

"No teams are available to join", how do I create one?


I am missing concrete steps as to how to configure a server to allow the first user to register as admin and enter the system console, or create teams.

Steps to reproduce

I have installed Mattermost from the Docker container and started the container using the default config file.

Expected behavior

I was expecting to be able to:

  • Register a user and have that user be an admin
  • Create a team
  • Enter the system console

This is even mentioned in the docs:

Create the first team and user. The first user in the system has the system_admin role, which gives you access to the System Console.

Observed behavior

I was first greeted by just the login page, without a possibility to register. So I went into the configuration and set EnableOpenServer to true. Now I could register the first user.

When I log in as that user, I now see:

No teams are available to join. Please ask your administrator for an invite.

But how do I create a team in the first place? I was expecting to land on a system console page, or get an option to create a team.

It therefore seems like the documentation does not reflect the actual steps required to a) enable user creation and b) create teams.

Any help would be appreciated.

Never mind, I noticed that an old database volume was not yet deleted.

I had to docker-compose stop && docker-compose rm and then rm -rf volumes to start fresh.

Hi @slhck I had the same issue with AWS beanstalk deployment. Can you help me? I tried with multiple times to create app from scratch, I have no luck.

Sorry, the only thing I know that helped was to nuke everything. If you already have one user set up, and consequently have one team already, you have to log in as that user and go to the System Console to manage the system. You may be able to use a CLI-based database access to find out what the respective user is.

Stop spamming. This is clearly a scamming link.

I am experiencing this exact behaviour. Also, I nuked everything and started from scratch—nothing changed. After creating a team via CLI and adding my account to that team, I still do not have access to the system_admin console. Any help would be appreciated! (Running a CentOS 7 with Plesk on it, installed docker-compose via SSH and then followed the official documentation/installation guidelines).

Thank you!

Hi @herzkerl, can you help check if your account has a system admin role - you can check it with the help of these docs:

Hi @amy.blais,

sure, I have double-checked that: docker exec mattermost-docker_app_1 mattermost roles system_admin ben doesn’t change anything. The other commands won’t work. (The first one from the second link only shows the help for the Mattermost command itself.)

Hi @herzkerl,

What is your AllowCorsFrom config setting set to? Also, can you help with these details as this sounds like a Websocket issue:

Hi @amy.blais, since I’m using docker, I checked the config-file ‘volumes/app/mattermost/config/config.json’.

“ServiceSettings”: {
“SiteURL”: “”,
“WebsocketURL”: “”,
“LicenseFileLocation”: “”,
“ListenAddress”: “:8000”,
“ConnectionSecurity”: “”,
“TLSCertFile”: “”,
“TLSKeyFile”: “”,
“UseLetsEncrypt”: false,
“LetsEncryptCertificateCacheFile”: “./config/letsencrypt.cache”,
“Forward80To443”: false,
“ReadTimeout”: 300,
“WriteTimeout”: 300,
“MaximumLoginAttempts”: 10,
“GoroutineHealthThreshold”: -1,
“GoogleDeveloperKey”: “”,
“EnableOAuthServiceProvider”: false,
“EnableIncomingWebhooks”: true,
“EnableOutgoingWebhooks”: true,
“EnableCommands”: true,
“EnableOnlyAdminIntegrations”: true,
“EnablePostUsernameOverride”: false,
“EnablePostIconOverride”: false,
“EnableLinkPreviews”: false,
“EnableTesting”: false,
“EnableDeveloper”: false,
“EnableSecurityFixAlert”: true,
“EnableInsecureOutgoingConnections”: false,
“AllowedUntrustedInternalConnections”: “”,
“EnableMultifactorAuthentication”: false,
“EnforceMultifactorAuthentication”: false,
“EnableUserAccessTokens”: false,
“AllowCorsFrom”: “”,
“CorsExposedHeaders”: “”,
“CorsAllowCredentials”: false,
“CorsDebug”: false,
“AllowCookiesForSubdomains”: false,
“SessionLengthWebInDays”: 30,
“SessionLengthMobileInDays”: 30,
“SessionLengthSSOInDays”: 30,
“SessionCacheInMinutes”: 10,
“SessionIdleTimeoutInMinutes”: 0,
“WebsocketSecurePort”: 443,
“WebsocketPort”: 80,
“WebserverMode”: “gzip”,
“EnableCustomEmoji”: false,
“EnableEmojiPicker”: true,
“EnableGifPicker”: false,
“GfycatApiKey”: “[redacted]”,
“GfycatApiSecret”: “[redacted]”,
“RestrictCustomEmojiCreation”: “all”,
“RestrictPostDelete”: “all”,
“AllowEditPost”: “always”,
“PostEditTimeLimit”: -1,
“TimeBetweenUserTypingUpdatesMilliseconds”: 5000,
“EnablePostSearch”: true,
“EnableUserTypingMessages”: true,
“EnableChannelViewedMessages”: true,
“EnableUserStatuses”: true,
“ExperimentalEnableAuthenticationTransfer”: true,
“ClusterLogTimeoutMilliseconds”: 2000,
“CloseUnusedDirectMessages”: false,
“EnablePreviewFeatures”: true,
“EnableTutorial”: true,
“ExperimentalEnableDefaultChannelLeaveJoinMessages”: true,
“ExperimentalGroupUnreadChannels”: “disabled”,
“ExperimentalChannelOrganization”: false,
“ImageProxyType”: “”,
“ImageProxyURL”: “”,
“ImageProxyOptions”: “”,
“EnableAPITeamDeletion”: false,
“ExperimentalEnableHardenedMode”: false,
“ExperimentalLimitClientConfig”: false,
“EnableEmailInvitations”: false

Do I need to connect with HTTPS to be able to use the admin panel?

Hi @herzkerl,

Can you help share the documentation/installation guides that you followed and I’ll take a look if there is something that might indicate what the issue might be. Also, do you see any log or Console errors?

Hi @amy.blais,

I used the official Docker install guide:
I have uncommented the edition line and my ports are:

  - "9280:80"
  - "9281:443"

I am using Plesk Onyx (newest release) and I set up a ‘proxy rule’ for my domain. (port 443 -> 9281). My console shows errors like:

29920#0: *1578140 recv() failed (104: Connection reset by peer) while reading response header from upstream

@pichouk This seems Docker related so decided to ping you as a next step - summary of issue:

  • herzkerl is not able to access the System Console on his server.
  • He nuked everything and started from scratch but nothing changed.
  • Using command docker exec mattermost-docker_app_1 mattermost roles system_admin didn’t help.
  • Config settings attached here
  • Console errors he sees
  • Running a CentOS 7 with Plesk on it, installed docker-compose via SSH and then followed the official Docker documentation/installation guidelines.

That’s weird.

So you do have access to the Mattermost server, you can connect with your account, the account is a system_admin but you cannot see the System Console, am I right ? If yes, it might be a (weird) Mattermost issue.
Or you didn’t have access to any kind of web page at startup ? If yes, it might be a Docker problem (or at least a webserver/reverse proxy one).

Do you have some logs from your app container ?

Right—but I was recently told that I need to connect with https to gain access to the System Console. If that’s correct, that may be the problem in that case.

Could you confirm that https access is needed for being able to see the system console? (I still haven’t managed to get it to work with https, though.)

It is better but there is no reason that the System Console cannot be accessed without HTTPS. Mattermost can totally work using HTTP (but it is insecure)

In Plesk, I created a proxy rule (, container mattermost-docker_web_1, 80 -> 9280) and I’m able to access the Mattermost server via http and https (sorry for the confusion).

The app container log shows:

Using existing config file /mattermost/config/config.json
Starting mattermost

‘docker ps’ shows:

a8e8a487abc3 mattermost-docker_app “/ ma…” 21 hours ago Up 21 hours (healthy) 8000/tcp mattermost-docker_app_1
d283696c8605 mattermost-docker_db “/ po…” 21 hours ago Up 21 hours (healthy) 5432/tcp mattermost-docker_db_1
2c1d7a73fb68 mattermost-docker_web “/” 21 hours ago Up 21 hours (healthy)>80/tcp,>443/tcp mattermost-docker_web_1

# docker exec mattermost-docker_app_1 mattermost version
Version: 5.3.0
Build Number: 5.3.1
Build Date: Wed Sep 19 07:42:35 UTC 2018
Build Hash: fd21e53365d504155ab87f9bef60b1ab4faeb38d
Build Enterprise Ready: false
DB Version: 5.3.0

# docker exec mattermost-docker_app_1 mattermost
Error: listen tcp :8000: bind: address already in use
  mattermost [flags]
  mattermost [command]

Today I’ve seen a (I’m pretty sure about that) new error message:

Please check connection, Mattermost unreachable. If issue persists, ask administrator to check WebSocket port.

If you need anything else, just let me know.

FYI, I am no longer using the web container—I have redirected to port 8000 of the app container. Problem is still not resolved.

Also, I upgraded to the latest version:

Mattermost Version: 5.4.0
Database Schema Version: 5.4.0
Database: postgres

Also, I created a new user account—just to double-check.

docker exec mattermost-docker_app_1 mattermost user create --email --password 12345 --system_admin --username test

Doesn’t look good though:

Teams you can join:
No teams are available to join. Please create a new team or ask your administrator for an invite.

I really don’t know what happen here. The only issue I understand is :

It means that your proxy doesn’t handle Websocket correctly. But if you use the web image this part should work out of the box.