Mattermost Peer-to-Peer Forum

MM iOS Client File Preview Not Available


#17

Hi @amy.blais. Is there someone online who can help me identify this issue?


#18

Thanks for following up,

My colleague was working on setting up a test environment to test it - I’ll ask him what the current status is.


#19

Ive created a test environment with the issue.

I can give him access.


#20

Thanks, can you help provide account details on the test server on pre-release - you can open a Group Message with me (amyblais) and my colleague (paul.rothrock).


#21

I’m still facing this issue.

It is really disappointing not to be able to use the files uploaded.

Can we raise the priority on this one a bit?

Cheers


#22

Hi @RbDev, Paul tested this on a same environment and wasn’t able to reproduce this, so we haven’t been able to determine what the cause of the issue might be unfortunately.


#23

The environment I configured can be used to replicate the issue.

I believe you and Paul have admin access to it.


#24

You can see the issue on my qa server.

You cannot watch nor download the videos.

You only see a red icon.

No videos have thumbnails, only the red icon:

Click on a video and you see this:


#25

@RbDev I can reproduce it on your server but it doesn’t reproduce on our servers so I can’t open a Jira ticket - can you help use the “Report a Problem” while you attempt to preview a text file or a video in case there are any log errors we can look at?


#26

I believe I mentioned some log erros related to permission on the old discussion and paul spotted the same later on.


#27

We need know what are you doing differently so that I can install on my qa server with your instructions and hopefully get this going.

Dont forget this is linux box so if you could also point out required libraries and version that could help.

Cheers


#28

Hi all,

Can I have some assist with this issue? Its a big let down not be able to use files uploaded to Mattermost.


#29

Hi @RbDev, I asked our devs about this and they asked if you can help verify the mime types of those files, at least in the database, and see if the mime type is correct?


#30

I’ve sent a “screenshot” of the database to @paulrothrock 31 August.

SELECT id,path,extension, mimetype FROM FileInfo;
±---------------------------±---------------------------------------------------------------------------------------------------------------------------------------------------------------±----------±-----------+
| id | path | extension | mimetype |
±---------------------------±---------------------------------------------------------------------------------------------------------------------------------------------------------------±----------±-----------+
| 8qt535h3jffg5y7i8zk7cyguge | 20180828/teams/noteam/channels/e7bx4waorjdbu8xt9ierjsrbar/users/qehaexbeejbn7rkfb7wshodmdw/8qt535h3jffg5y7i8zk7cyguge/IMG_0208.mp4 | mp4 | |
| byzuuc15w78f7cgiy4te5cy83e | 20180826/teams/noteam/channels/e7bx4waorjdbu8xt9ierjsrbar/users/qehaexbeejbn7rkfb7wshodmdw/byzuuc15w78f7cgiy4te5cy83e/Note.txt | txt | |
| eejsonunb3rdppkt4rp5p7gcxo | 20180828/teams/noteam/channels/e7bx4waorjdbu8xt9ierjsrbar/users/ufnwtuyo9fne3f5w68184k61ko/eejsonunb3rdppkt4rp5p7gcxo/rename-channels.mp4 | mp4 | |
| pkym3rwjufdxpcoidqa5s6zpce | 20180826/teams/noteam/channels/e7bx4waorjdbu8xt9ierjsrbar/users/qehaexbeejbn7rkfb7wshodmdw/pkym3rwjufdxpcoidqa5s6zpce/a9c5d4a5-68dc-4616-8a73-bfbf5ff02acd.mp4 | mp4 | |
| smad9s3fjjnguj5a3d6po1q9je | 20180826/teams/noteam/channels/e7bx4waorjdbu8xt9ierjsrbar/users/qehaexbeejbn7rkfb7wshodmdw/smad9s3fjjnguj5a3d6po1q9je/15 - Black Ice.m4a | m4a | |
| t4wcgc5ftp88fqk74ex6m7q85c | 20180826/teams/noteam/channels/e7bx4waorjdbu8xt9ierjsrbar/users/qehaexbeejbn7rkfb7wshodmdw/t4wcgc5ftp88fqk74ex6m7q85c/Mona Lisa.jpg | jpg | image/jpeg |
| xz9rnn45x3dtdb7paxgrubjsuw | 20180828/teams/noteam/channels/e7bx4waorjdbu8xt9ierjsrbar/users/qehaexbeejbn7rkfb7wshodmdw/xz9rnn45x3dtdb7paxgrubjsuw/IMG_0208.mp4 | mp4 | |
| ygispmqgz38w5ch3uya6ohmf6w | 20180826/teams/noteam/channels/e7bx4waorjdbu8xt9ierjsrbar/users/qehaexbeejbn7rkfb7wshodmdw/ygispmqgz38w5ch3uya6ohmf6w/9c39756b-72ce-45df-bafd-faa4eef66c09.mp4 | mp4 | |
±---------------------------±---------------------------------------------------------------------------------------------------------------------------------------------------------------±----------±-----------+

SELECT id,extension, mimetype, width, height, haspreviewimage FROM FileInfo;
±---------------------------±----------±-----------±------±-------±----------------+
| id | extension | mimetype | width | height | haspreviewimage |
±---------------------------±----------±-----------±------±-------±----------------+
| 8qt535h3jffg5y7i8zk7cyguge | mp4 | | 0 | 0 | 0 |
| byzuuc15w78f7cgiy4te5cy83e | txt | | 0 | 0 | 0 |
| eejsonunb3rdppkt4rp5p7gcxo | mp4 | | 0 | 0 | 0 |
| pkym3rwjufdxpcoidqa5s6zpce | mp4 | | 0 | 0 | 0 |
| smad9s3fjjnguj5a3d6po1q9je | m4a | | 0 | 0 | 0 |
| t4wcgc5ftp88fqk74ex6m7q85c | jpg | image/jpeg | 1354 | 2048 | 1 |
| xz9rnn45x3dtdb7paxgrubjsuw | mp4 | | 0 | 0 | 0 |
| ygispmqgz38w5ch3uya6ohmf6w | mp4 | | 0 | 0 | 0 |
±---------------------------±----------±-----------±------±-------±----------------+

mimetype, width, height and haspreviewimage are mostly empty. Only pictures are getting populated.


#31

Thank you @RbDev, I’ll ask our devs about this.


#32

@RbDev Devs have further questions:

  1. What OS is the server running on? The list of mime types it recognizes is provided by the OS outside of some simple cases that Go supports by default.
  2. Are there any errors reported when uploading the non-jpeg files? I think you mentioned some permission errors so sharing those will be helpful.

#33
  1. OS: RHE 7. I have other Linux OSs like QTS, BSD, Debian and they have the same behaviour.
    The QA box is a Amazon Linux system and I’m happy to give access to the box for the devs to play around.

  2. When uploading files I don’t think there are error messages. We could test it on the QA box later on if you like.


#34

@RbDev Thanks, I’ll ask Paul to look at this further.


#35

@RbDev I asked the team about this and we are thinking that this might be a server configuration issue.

You can see more details on this old ticket - basically a recommendation would be to install a media player or other browsers on the server which would add the missing mime types and make it work.

One person here was able to resolve a similar issue with the tips above: https://github.com/mattermost/mattermost-server/issues/8929#issuecomment-396608655.


#36

Yes thats it. you need mailcap installed for video preview to work.

Please this must be included in the installation guide.


But movies dont get thumbnails and music is not playing even on prerelease.

Is this under development? if not please create a ticket.

Cheers