We're Hiring!

Mattermost, Inc.

Migrating to new server plus upgrade

Hello,

I’m currently running Mattermost 5.12.0 on a Debian 8 server. I’m looking for a migration path to the current version Mattermost 5.27.0 on a Debian 10 server.

I’ve read the migration guide, which indicates both servers must be running the same database version. This is not possible of course between Debian 8 and 10. As well, I can’t simply upgrade Mattermost in-place on the Debian 8 server to 5.27.0 because it requires MySQL 5.6+, and Debian 8 tops out at 5.5.

So I’m at a loss as to how I can get my installation up to the latest version on a new server. Any thoughts?

Thank you!

Hello! If you create a backup of your current database of your existing Mattermost server, and then import it to the new server, in a database called mattermost, as it would be installed, and then install the latest version of mattermost, It should work. I have had this same issue, and I found that when installing the latest version, it will prompt me if I want to update the existing database schema to the latest version when installing. If you have any issues with this or it doesn’t work, please let me know and I’ll see what I can do!

1 Like