We're Hiring!

Mattermost, Inc.

Migrate Auth to OpenID not supported in CLI

Hi,

I am trying to force migrate to OpenID connect through the CLI. However, it seems to_auth openid is not yet supported.
I am running the latest version [ 5.34.2]

Command: mattermost user migrate_auth --auto email OpenID
Error: Invalid to_auth parameter, must be saml or ldap.

How can I force login method to OpenID?

Hello, @reaba

The migrate_auth CLI only supports email, saml, or ldap as mentioned in the documentation.

May I know if you have configured your Mattermost instance to use OpenID and have performed the conversion from the UI as mentioned here?

Hi @ahmaddanial Yes I configured Mattermost to use OpenID from the UI.
However, I want to enforce the current users to use OpenID instead of their emails to login.

Hi, @reaba

Got it. So enforcement of OpenID instead of email for login.

Have you considered disabling the following in System Preferences > Authentication > Email and see if it works the way you prefer?

Yes. it didn’t work. current users will lose access if they have email as a login method. they need to switch to openID before we can disable this option