Mattermost, Inc.

Messages stuck sending, forced to restart app

Hello, two users in our company, both on macs (one the latest OS and the other Mojave 10.4.1) using the desktop app, have started seeing issues where messages will not send. They are stuck greyed out with a little pending circle on the right.

Both users are still able to receive messages at this time and everything else functions as normal.

The only way to start sending messages again is to restart the app. After that they send normally for a while (sometimes a day, sometimes just an hour or so), then the issue comes back.

We have tried updating to the latest version of mattermost and the issue keeps coming back.

This can be very frustrating as the users do not always notice that it has started until they realize nobody is responding to them. When they restart the app, all the “pending” messages are gone and they have to retype everything.

We started seeing this issue a few days ago and I’m concerned other users are experiencing it but not reporting it.

Seems just like forum posts 7012.

Server:
Version: 5.5.0
Build Number: 5.5.1
Build Enterprise Ready: true
DB Version: 5.5.0
Linux sv-mattermost01.luma.la 3.10.0-514.6.1.el7.x86_64

Would you be open to upgrading your server version? Our support supported server versions included 5.19 and higher. Also, what desktop app version are you on?

1 Like

Hi there, @aka

On top of the suggestion by @amy.blais to ultimately upgrade your Mattermost Server to the supported version of Mattermost Server (at least 5.19), may I know if the 2 users are facing the same issue when they utilize the web browser as well based on the supported ones here?

started seeing issues where messages will not send. They are stuck greyed out with a little pending circle on the right.

Can you also share a screen shot of what they are seeing here? Are there any errors shown on the desktop app when the messages are not sent?

1 Like

Hello, thank you for your responses and sorry for my late reply. The issue has randomly stopped happening and my team has not had the time to troubleshoot while supporting our users working from home but we will test this out if the issue returns. Thanks again!

2 Likes

Hi, @aka

No worries. Feel free to revisit this if the issue pops up again. Take care and stay safe!