Mattermost TLS Setup


#1

I have installed mattermost with the one click Docker install from their website and I have access to the web interface from the ip address. I want to replace my IP with a domain name. since mattermost is on port 8065, you have to put 8065 to port 80 or 443. I have on the web GUI that i want my port to be 443 and TSL is ENABLED. According to the documnetaiton on mattermost’s website, theres something else i need to do in the command line. I did: cd /opt/mattermost/bin which returned with a “no such directory” and sudo setcap cap_net_bind_service=+ep ./mattermost Which responded with the same “no such directory” I restarted my server thinking it actually did but… it didn’t work. Any help you guys could give me would be amazing. I don’t know this stuff… Thanks!


#2

Hi @AustinConner! Thank you for reaching out.

Can you help with more details on your server version and any relevant config settings and logs?
Can you also help confirm if this was the documentation you were following: https://docs.mattermost.com/install/config-tls-mattermost.html?

Thanks!