Mattermost, Inc.

Mattermost support for IE 11 (windows 7?)

We have some users on Internet Explorer 11, and mattermost isn’t displaying correctly.

The screen is white with a “Back” label at the top, and a footer at the bottom.

I see that IE11 is supported, but it’s not working for us. Any tips?

Greeetings,
I do have the same problem with IE 11. We are using Mattermost Team Edition 2.10:
Build Date:Mon Mar 14 20:45:23 UTC 2016
Build Hash:f189bc2073cf800c5f4506a69bdb51d7065269bf

My IE version is:
11.0.9600.18230

P.S.:
It works correctly on Chrome…

What operating system are you running on, steffen? Is it also Windows 7?

Also, do you have compatibility mode enabled? We only support IE11 without compatibility mode

Hi hmhealey,

Yes, I’m using WIndows 7 and yes, it works fine without compatibility mode.
Thanks!

Cheers,
Steffen

Weird. I’ve removed all the domains for the list in compatability mode settings, in other words i’ve turned off compatability mode, but it’s still not working.

Hey vikingsteve,

If you’re hosting mattermost on your local network, there could be a chance that compatibility view is still enabled for all sites in your intranet

If that’s not checked, can you check the development console to see what document mode is being used by the browser? You can get to it by clicking the gear icon in the top right corner, selecting the “F12 Developer Tools” option, and then going to the “Emulation” tab of the window that opens up. It should look something like this

Right, thanks hmhealey. It turns out our intranett (mycompany.com) is configured to run in compatability mode by the group policy.

In the first picture you posted, “Display intranet sites in Compatability View” is not ticked, but it is actually greyed out.

When I got into F12 developer tools, Emulation, the user agent string is “standard” (not IE 10). But when I change it to EI10 and reload the page, compatability mode gets put back on via the group policy.

I guess I need to talk to my admin about allowing “chat.intra.mycompany.com” to NOT be forced into compatability mode, even if “mycompany.com” sites are forced to.

(unless you know a way to force override for a specific site, locally in the browser, to override the group policy and turn compatability mode OFF ??)

I’m not aware of any ways to locally override the group policy, although I haven’t looked into it much myself. I also looked into seeing if there was a header or something we could add into Mattermost itself to force compatibility mode off, but the best I could find with the group policy enabled would force it into IE8 rendering mode which still probably wouldn’t work.

If you happen to find a good way to solve the problem, let me know and I can get it included into our documentation.