Mattermost, Inc.

Mattermost not serving on default port 80

Hi there!

I installed my mattermost server on digital ocean VPS running on Ubuntu 18.04.

As per the link https://docs.mattermost.com/install/install-ubuntu-1804.html# I did host my mattermost instance but am not able to access on default port 80. i.e. I am not able to access at http://mydomain.com but i am able to access at http://mydomain.com:8065

Can anyone please help me to understand though we configured NGINX as proxy for the mattermost server still why its not accessible at http://mydomain.com
My mydomain.net config file as follows:

upstream backend {
server localhost:8065;
keepalive 32;
}

proxy_cache_path /var/cache/nginx levels=1:2 keys_zone=mattermost_cache:10m max_size=3g inactive=120m use_temp_path=off;

server {
listen 80;
server_name myexample.com; (i used my domain here)

location ~ /api/v[0-9]+/(users/)?websocket$ {
proxy_set_header Upgrade $http_upgrade;
proxy_set_header Connection “upgrade”;
client_max_body_size 50M;
proxy_set_header Host $http_host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Forwarded-Proto $scheme;
proxy_set_header X-Frame-Options SAMEORIGIN;
proxy_buffers 256 16k;
proxy_buffer_size 16k;
client_body_timeout 60;
send_timeout 300;
lingering_timeout 5;
proxy_connect_timeout 90;
proxy_send_timeout 300;
proxy_read_timeout 90s;
proxy_pass http://backend;
}

location / {
client_max_body_size 50M;
proxy_set_header Connection “”;
proxy_set_header Host $http_host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Forwarded-Proto $scheme;
proxy_set_header X-Frame-Options SAMEORIGIN;
proxy_buffers 256 16k;
proxy_buffer_size 16k;
proxy_read_timeout 600s;
proxy_cache mattermost_cache;
proxy_cache_revalidate on;
proxy_cache_min_uses 2;
proxy_cache_use_stale timeout;
proxy_cache_lock on;
proxy_http_version 1.1;
proxy_pass http://backend;
}
}

Thanking you in advance.

Hi,
Did you try this command?

sudo setcap cap_net_bind_service=+ep /opt/mattermost/bin/mattermost

Hi Ali
Thanks for your reply. I didn’t try the command you mentioned. Let me try this. Is there any other setting that I need to test or check…