We're Hiring!

Mattermost, Inc.

Mattermost File sharing

Hi, I have file sharing enabled, however unless a user is an administrator, the option to attach a file isnt available. Any solution for this?

Hello, @jcr

I believe that you have the following setup in your System Console for now. File Sharing is a a server-wide configuration, so there is no default way of restricting per user account type.

Since you mentioned that file sharing is disabled if the user is not an administrator, I would like to confirm on the following:

  • What version of Mattermost Server installed and desktop app is the affected user running on?

  • Is the issue reproducible across all platforms (desktop / web / mobile) for the affected user?

  • Is the problem happening across all channels and all teams?

  • Can you provide the screen shot of the absence of the file upload paper clip icon from the client?

  • Is the affected user on a normal account / Guest access account?

Keep me posted.

Hi
I figured out a way to get the upload option to appear by making the user an administrator then removing the admin rights

Hello, @jcr

Thanks for sharing the solution. Out of curiosity, was this issue happening to one specific user or is it happening to every normal users in general? I just want to understand if there was something broken which required you to switch the user account to an administrator before removing it again.

just one user in this example but I havent tried it with a more users

Hi, @jcr

Interesting. Let me know if you encounter it with other users too since it is worth investigating especially when file sharing permission is only configured on a global level (on / off) and there is no permission scheme available for specific user types.