Mattermost Peer-to-Peer Forum

Mattermost does not work on 443 (https) - Docker - Error: CONNECTION_REFUSED

#1

Hello community,

my Mattermost installation (Docker) does not work on 443 (https). I get always “CONNECTION_REFUSED”. Can someone please tell me what I did wrong?

docker-compose.yml

  web:
    build: web
    ports:
      - "80:80"
      - "443:443"
    read_only: true
    restart: unless-stopped
    volumes:
      # This directory must have cert files if you want to enable SSL
      - ./volumes/web/cert:/cert:ro
      - /etc/localtime:/etc/localtime:ro
    environment:
      - MATTERMOST_ENABLE_SSL=true

ls -la ./volumes/web/cert

-rwxr-xr-x 1 root root 1911 Mär 20 23:14 cert.pem
-rwxr-xr-x 1 root root 3558 Mär 20 23:14 fullchain.pem
-rwxr-xr-x 1 root root 1704 Mär 20 23:14 key-no-password.pem

docker-compose up

db_1   | AWS_ACCESS_KEY_ID is required for Wal-E but not set. Skipping Wal-E setup.
db_1   | AWS_SECRET_ACCESS_KEY is required for Wal-E but not set. Skipping Wal-E setup.
db_1   | WALE_S3_PREFIX is required for Wal-E but not set. Skipping Wal-E setup.
db_1   | AWS_REGION is required for Wal-E but not set. Skipping Wal-E setup.
db_1   | LOG:  database system was shut down at 2019-03-20 23:33:49 UTC
db_1   | LOG:  MultiXact member wraparound protections are now enabled
db_1   | LOG:  autovacuum launcher started
db_1   | LOG:  database system is ready to accept connections
app_1  | Using existing config file /mattermost/config/config.json
web_1  | found certificate and key, linking ssl config
web_1  | ln: /etc/nginx/conf.d/mattermost.conf: File exists
app_1  | Configure database connection...OK
app_1  | Starting mattermost

curl -I https://chat.mychat.de

Failed to connect to chat.mychat.de port 443: Connection refused
#2

Pinging @pichouk to take a look

#3

Are you behind another proxy/reverse-proxy that might refuse the connection ?

Also, are you able to directly curl the app container ? To find out if the error is from app or web container.