We're Hiring!

Mattermost, Inc.

Mattermost dead after attempted upgrade

Summary

Mattermost can’t connect after attempting upgrade

Steps to reproduce

Had Mattermost 5.25 running on CentOS 7 box with nginx proxy.
Server was running PostgreSQL 9.4
Attempted to upgrade to 5.28 by following the steps on the upgrade page.
Upon starting mattermost no errors or logs at all are generated, just stays started in /var/log/messages
Nothing in the mattermost.log file
Browse to the mattermost public URL and nginx returns a 400 error.
Browse to the mattermost internal URL and it returns a page that says “Cannot connect to Mattermost. We’re having trouble connecting to Mattermost. If refreshing this page (Ctrl+R or Command+R) does not work, please verify that your computer is connected to the internet.”
Tried upgrading to postgres 10 after seeing the note about 9.4 going out of support, no difference.
Tried restoring the mattermost backup directory taken during the upgrade back to 5.25 and then starting mattermost again, no difference.
Running mattermost manually from command line does not show any output.
Not sure what else to try?

Figured it out, nginx was set up to handle the TLS connections, but in the mattermost config.json file it also had TLS security turned on. Removing that enabled it all to work again. Not sure how/why that was set in the config file that caused it to stop working, weird.

1 Like

It sounds like the upgrade script/upgrade files may have either had TLS enabled on default, or have enabled it as a default in its upgrade progress. Either way, I’m glad to hear you got it figured out!