We're Hiring!

Mattermost, Inc.

Mattermost android recommended client

Good afternoon,

What’s the most recommended app for accessing Mattermost from Android?. It seems the one that better works across all versions to be the Mattermost classic app… I have seen for instance the Mattermost beta and the Mattermost (as it’s named) app, not to be able for instance of adding new channels…

What’s the recommended one?. The classic?.

Cheers!

What Android version, Mattermost mobile app version, and Mattermost server version are you on?

Hi, @egoitzr

It depends really on the features and limitations of the particular platform. May I know if you have encountered other issues with the stable release of Mattermost Android app besides not able to add new channels?

Does the user who encountered the issue has the right permission for that based on the Advanced Permissions feature?

Just want to understand what can be improved and share the feedback to the Android team for a better user experience. Thanks.

Good morning,

We have changed the Gitlab auth page. I wanted to just be sure it didn’t affect to mobile clients. So I tested under Android the three clients you can download from Google play (I saw it seems not to be issues with the page) :

  • Mattermost
  • Mattermost classic
  • Mattermost Beta

I saw that with Mattermost Classic in Android 9-rc2 and 7 the app seems to work better. You can click in the plus icon of new channel, or new direct message… but not in the Mattermost or Mattermost beta app (all of them downloaded from Google play).

That made me wonder, what could be the recommended app. And that’s the reason of the question :slight_smile:

Cheers,

Sorry the server version is the last one 5.24.2 I think…

Cheers!

I ask it in a general manner… or does exist a recomendation for each Android version?. It’s just for knowing and recommending the best app for each case…

Cheers,

Hi, @egoitzr

Got it. In general:

  • Classic was last updated in 2018, which means that it was catered for older versions of Android OS (4.4 and up) until stable release of 1.14.0 if I am not mistaken.
  • Stable release is meant for general usage. Tested for stability and features that does not break the app.
  • Beta introduces new features and unstable. It is offered as a release candidate before the features gets cut to official release.

Starting Mattermost 1.15.0, the changelog highlights a clearer message on the supported environment:

Server Versions Supported: Server v4.10+ is required, Self-Signed SSL Certificates are not supported unless the user installs the CA certificate on their device

Android operating system 7+ is required by Google.

In my opinion, it is best to run on the stable version of Mattermost app and server at all times. :+1:

Hi!

Then I’ll have to see why I couldn’t open new chat dialog or new channels in Android 9 rc2 (Android x86 project) vm.

Will give a try too to Android 8.1 (from the same project in order to see if it works…) perhaps…

Thanks!!

1 Like