Mattermost, Inc.

Making QNAP's Mattermost Accessible Online

Hi,

Recently purchased QNAP Network Attached Storage as a fileserver for my small business but also as a server for Mattermost. Mattermost is working just fine on my local ip: 192.168.1.xx:8065. And for that reason, I’m wondering how I can also make it available online so I can communicate with employees remotely. I’ve read in some forums that I need to port forward my business’s static IP to the 8065 port, but I’m not entirely sure how to do that or if its the right way to do that since I’m not an IT professional.

Any helps and links are greatly appreciated!

Hi @myleschuabebe, thank you for reaching out!

I’m not sure of the steps to do this either, so I am just giving you a heads-up that I will ask our engineers to give simple steps for port forwarding a static IP to the 8065 port (or other steps if this is not the right way).

Hi @myleschuabebe,

I’m not really familiar with qnap, but the Synology Nas have a module called “Reverse Proxy” where you can expose web applications through the webserver stack of the nas. This would have the benefit that you can also let the nas handle ssl for you (when just forwarding 8065 to the world all communication will be plain text and for the world to sniff in on your communications).

Hi Guys,

I figured out the error to why it doesn’t work. I’m able to port forward to 8065 now, but I can’t port forward securely.

Steps:

  1. Installed Mattermost from the QNAP AppStore
  2. Signed up as the First User in Mattermost -> Become Default System Administrator
  3. Went to the console and made the siteURL into my company specific static IP https://xxx.xx.xx.xx:8067, which is also accesible via (https://xxxxxxx.myqnapcloud.com:8067). Fyi, this is the FREE domain name given by QNAP so that you always connect via SSL to their in-house services (does not apply to Mattermost according to their product page).
  4. When I change the listening port to :443 just like the installation guide says (in order to enable TLS security), that’s where I start encountering problems. I’m told that I need to restart the Mattermost app if I change anything besides the siteURL. Then after it boots up, it won’t start again. Trying to access port 443, 8065 or 8067 locally gives me error for “too many redirects”.
  5. At this point, I have to uninstall and reinstall agan.

So realy, everything is fine except Step #4. When I change the listneing port from :80 by default to :443 like the installation guide says so, I can no longer access Mattermost by going to port :443, :8065 or :8067 locally according to Mattermost docs.

If I skip #4, I can now access my Mattermost locally and remotely via port forwarding from router. But I’m always given the “not secure” connection.

According to a rep I spoke to, QNAP NAS runs Mattermost on Docker, which it’s local storage can be accessed via SFTP SSH. I’m not sure if this piece of information helps.

seems whoever put that app online, did not think it through to the end.

Searching a bit through the web https://boshdirect.com/tech/multiple-servers-from-one-port-on-nas comes closest to what you are looking for (in a direct relation to qnap at least). The one caveat you have to be aware is that you have to configure the reverse proxy for https://mattermost.youdomain.com and not https://youdomain.com/mattermost, since Mattermost does not support the latter.

With these changes you also do not need to change the port within Mattermost itself, since the Reverse Proxy will take care of all https stuff. So just to be super explicit the connection is then:

https://mattermost.youdomain.com -> reverse proxy -> http://mattermost:8065

edit: https://emby.media/community/index.php?/topic/56909-how-to-setup-reverse-proxy-access-to-emby-on-qnap/ has a similar topic, but omits the https part