Matttermost, Inc.

Mac MM client timezone is off by one hour

Hi it looks like my MM native client on Mac isn’t dealing very well with timezones.

Im in Quintana Roo, Mexico, or Cancun time. That is UTC-5 year around and no daylight savings. But it looks like my MM client is forcing UTC-4 instead of UTC-5. Is there any way to get it to respect my Macs timezone or edit the timezone directly for this app?

 andreas@blackops  ~  sudo systemsetup -gettimezone
Time Zone: America/Cancun

MM behaves correctly using a web browser the issue seems to be only in this app.

Hi @arosl, what Mattermost server and app versions are you on? Do you have Timezone setting enabled (https://docs.mattermost.com/administration/config-settings.html#timezone)?