Mattermost, Inc.

Jira Plugin - Failed to get a connect li nk

Summary

When running /connect jira and clicking on the link I get failed to get a connect link: Post https:///plugins/servlet/oauth/request-token: x509: certificate signed by unknown authority. I have set
“EnableInsecureOutgoingConnections”: true,
“AllowedUntrustedInternalConnections”: “”,
in config.json and restarted the docker image.

Steps to reproduce

Running Team Edition 5.12.0 from the official docker image.

Expected behavior

It would connect or at least use the AllowedUntrustedInternalConnections to not display cert error.

Hi @flyingowl, would you be open to sharing more details on your Jira config settings: https://github.com/mattermost/mattermost-plugin-jira#2-configuration?

Definitely, that is the guide I followed to set it up and used to configure it. The Jira server is using a certificate from our corporate CA. We are using Jira 8.0.x. If there’s any other details you need let me know.

Hi @flyingowl, I asked community about this and they said that EnableInsecureOutgoingConnections configures only Mattermost and not the Jira Plugin.

1 Like

Trying to pick this up again, can anyone assist in understanding what is causing the issue? Mattermost is using a certificate from a trusted CA and Jira is running with a certificate from our internal enterprise CA.

Is the internal CA also trusted in the certificate store of the Mattermost server?

1 Like

No, but to do that would require a custom docker container, which I’d like to avoid. If this is the only way to fix it I’ll do it. Ideally I’d like to be able to mount an additional CA via a mounted file or config change.