Issues with TLS


#1

Hello everybody,
I’m having issues with TLS enabling. In my server I configured a lot of virtualHosts plus the mattermost files. In http everything was working fine.

Today I tried to setup TLS and https. I followed the instuctions as in https://docs.mattermost.com/install/config-tls-mattermost .html. Now I get this:

Please notice the error: I’m trying to access domain1.mywebsite .com and the error is “its security certificate is signed by domain2.mywebsite .com”. domain2.mywebsite .com is one of the websites configured as virtualhosts in apache.

I did not configure any virtualhost for Mattermost, since I don’t thing any is needed (and it worked flawlessly without one, and without TLS). But how can I tell mattermost (or the browser?) that the server of domain2.mywebsite .com is the same of domain1.mywebsite .com?

I generated the certificates using letsencrypt with the standalone option (sudo certbot certonly --standalone -d domain1.mywebsite .com) and didn’t move any file, just enabled “UseLetsEncrypt”: true, in config.json file.

Do you happen to have any idea about how I could fix this?

Thank you
Marco


#2

Hi Marco, are you using NGINX?
If not, you don’t need to use certbot.
If you are, can you post your nginx configuration?


#3

Hello hwcltjn,
thank you for your kind answer! Actually I’m not using Nginx, I just have an Apache installation (as far as I know). Why should I not need certbot?


#4

So you’re running Apache and Mattermost on the same server correct?

Which ports are you using for Mattermost?
Does your website have it’s own SSL certificate?
Can you post your Apache config? I’m not great with Apache but it might help with troubleshooting.


#5

Hi @MarKco, Following up on this - did you receive assistance to this elsewhere or do you still need help with this? If you still need assistance please let me know and I will ask one of our engineers to take a look.


#6

Hello Amy,
to be honest, in the meantime my boss decided Mattermost is not so much better than Skype for our needs (sorry to have to write that) and therefore we removed it from our servers.

Thank you for asking, anyway, that was very kind.

Good night
Marco


#7

Sorry to hear this @MarKco :frowning:

Please let us know if you need help installing in the future and we’ll be happy to assist :+1: