Mattermost, Inc.

[Issue] Can't send emails

Hello,

I’ve just installed and configured Mattermost on a ubuntu Vps and I got an issue with sending emails.

Summary

After installing, configuring, and testing Mattermost on my VPS, I have one major issue. Mattermost can’t send emails.
I configured the smtp parameters, I don’t have any errors when testing it, even have the confirmation message that is works “No errors were reported while sending an email. Please check your inbox to make sure.”, but it doesn’t send any mails.

Steps to reproduce

Mattermost Version: 5.13.2
Database Schema Version: 5.13.0
Database: mysql

Smtp parameters :
SMTP Server: mail.infomaniak.com
SMTP Server Port: 587
SMTP Server Username: [my email address]
SMTP Server Password: [my password]
Connection Security: TLS

Test connection result :
No errors were reported while sending an email. Please check your inbox to make sure.

Expected behavior

The emails should be send when testing the connection, or using “forgot my password”.

Observed behavior

Despite the connection test being successful, the application is not sending anything. I already checked the log with my smtp provider, the emails or not rejected, there is just nothing send through the address.

Update on the issue :

I used an other mattermost user to test a new password request (not hosted in gmail this time) and I received an email.

But, the from is empty, and, looking into the headers, I see that it wast send by my server localhost, and not via the smtp relay used on the SMTP configuration tool on mattermost :confused: .

@Zeukat Are there any related errors in the Mattermost Server Logs (via System Console > Logs)?

Also, I’m sure you did based on your report, but confirming you used these steps to set up your SMTP? https://docs.mattermost.com/install/smtp-email-setup.html