Mattermost, Inc.

IOS App problem with WebSocket port (appears with v3.3.0 and 3.4.0)

With IOS app i got this message all the time since 3.3.0 and 3.4.0:
" Please check connection, Mattermost unreachable. If issue persists, ask adminsitrator to check WebSocket port."

From 3.2.0 to 3.3.0
didn’t change anything in config.json or nginx.conf (in conf.d):

server {
listen 80;
server_name sllmatter.se;
return 301 https://$server_name$request_uri;
}

server {
listen 443 ssl;
server_name sllmatter.sll.se;

ssl on;
ssl_certificate /etc/nginx/conf.d/sllmatter.pem;
ssl_certificate_key /etc/nginx/conf.d/sllmatter.key;
ssl_session_timeout 5m;
ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
ssl_ciphers ‘EECDH+AESGCM:EDH+AESGCM:AES256+EECDH:AES256+EDH’;
ssl_prefer_server_ciphers on;
ssl_session_cache shared:SSL:10m;

location / {
gzip off;
proxy_set_header X-Forwarded-Ssl on;
client_max_body_size 50M;
proxy_set_header Upgrade $http_upgrade;
proxy_set_header Connection “upgrade”;
proxy_set_header Host $http_host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Forwarded-Proto $scheme;
proxy_set_header X-Frame-Options SAMEORIGIN;
proxy_pass http://127.0.0.1:8065;
}
}

I don’t believe anything relevant in the code base changed.

Can you try

  1. reaching your server from the mobile web browser and see if the message happens there as well?
  2. see if it happens from a desktop web browser or the desktop apps?

I actually encounter the same behaviour, though it seems different on devices and apps.

iphone : ios10
neither safari nor mattermost app do get websockets connections

ipad : ios9
safari : no websockets
mattermost app : works fine

it doesnt matter if it’s wifi or cell.

Browserapps on multiple Desktops work fine, so its no a basic problem with websockets

Use url with http instead of https

@loosi,

Can you confirm that using HTTP:// instead of HTTPS:// solves the issue for you?

I had facing the same issue.

While using https://mm.mydomain.com:5443 at IOS app, websocket error pop.
While change to http, the app shows " We could not connect to the Mattermost server or the server running in an incompatible version".

The SSL cert keys generated by myself (I’m not own a real cert) and persist to use HTTPS for all connections.

@longzhiw, can you confirm you have the latest version of the iOS app installed?

same problem here.
I have used self signed SSL certificate(accessing by ip:port) and have WebSocket issue in iPad and iPhone. How can fix it with storing SSL?

Hi @sap,

Thanks for your feedback.

Does [this reply] from prixone help?