Mattermost, Inc.

Impossible to use MM with iOS 10.3.3

Hi !

Few days ago I re-installed mattermost on my iPhone 5c (iOS 10.3.3, App version 1.31.2, iOS compatible according to the Apple Store informations). I can login but when tchats appear, the app shows this message (see attach) and shutdown itself.

I continue to receive notifications when someone tag me but I can’t see the message in the App :frowning:

Someone have any idea ? I tried with Mattermost “Classic” but i can’t login, my “browser” is not supported.

Thanks !

We currently support iOS versions 11+ (please see https://github.com/mattermost/mattermost-mobile/blob/master/CHANGELOG.md#1312-release).
What Mattermost server version are you on?
Are you able to log in via a browser?

Server version : 5.23.0

Impossible to join with Safari, i tried with Google Chrome. Last version available for iPhone 5c : 71.0. After the login, page charge endlessly :frowning:

Why the “low” version of Mattermost (mattermost classic) is not available for theses old phones ? :frowning:

Thank for replying ! :slight_smile:

What browser versions are you on?

Hello, @MedStudFR

To help us understand the issue better with the device that you are using, can you please take a screen shot of what you are seeing on the mobile web browser when you tried to log in?

Since you you mentioned that you hit into this issue after reinstalling the Mattermost mobile app based on the statement here;

Do you recall the Mattermost mobile app version that you were running on that was working? I will be able to provide you with the .ipa file for you to install it again and verify if it is working correctly.

From there, we will be able to verify if there is something with the latest mobile app that is not playing nice with the environment that you are on:

  • iPhone 5C

  • iOS version 10.3.3

Additionally, you mentioned that you are also having issues with the Mattermost Classic app. Can you grab a screen shot on what error you were getting with the Browser not supported message?

I will post there because I had bad experience with Mattermost support but I think I have few luck to be helped:

  • The problem in the mobile app is independent of the server version, it happens with all iDevices having iOS 10
  • The problem seems to have appeared with the mobile app v1.30.1 so the releases before should work.
  • You say you can provide an older .ipa file but are you really sure that we can install it without the AppStore? I thought it was impossible.
  • It is unfair from you to release an app in the AppStore which is not working and they say that you don’t support it. Any user who will update his app will be stuck with that as it impossible to revert back an update in iOS.
  • iOS 10 use Safari 10, and with the new server versions we get a message that only Safari 12+ is supported.

Hi, @jean

Allow me to understand the issue a little better here. Can you please provide the Mattermost Server version that you are on?

Additionally, you mentioned that the issue happens on all iDevices running iOS 10. Based on the mobile changelog, we start to support iOS 11+ starting 1.17.0:

iPhone 5s devices and later with iOS 11+ is required.

Since the devices are running on the older iOS, what models are you referring to? Are they able to upgrade to the latest version of iOS?

You say you can provide an older .ipa file but are you really sure that we can install it without the AppStore? I thought it was impossible.

Which version of iOS mobile app are you referring to? Can you elaborate a little bit on what you mean by “installing without AppStore”?

It is unfair from you to release an app in the AppStore which is not working and they say that you don’t support it. Any user who will update his app will be stuck with that as it impossible to revert back an update in iOS.

The app releases in the AppStore should work with the supported environment by default (iPhone 5s devices and later with iOS 11+ is required). Can you please confirm again if the affected users are running on the supported platforms? If yes, I would like to gather more details on the issue such as the screen shot / screen recording of the problem as well as verifying if the problem happens on all iOS users in the server.

iOS 10 use Safari 10, and with the new server versions we get a message that only Safari 12+ is supported.

Circling back to the iOS version question, may I know what type of device and what is the latest version of iOS can it upgrade to?

Hi,

Allow me to understand the issue a little better here. Can you please provide the Mattermost Server version that you are on?

I have the problem described above with a server with version 5.22.2, but I tested many other server versions and a bug that I always get is a crash when trying to type in the chat.

Additionally, you mentioned that the issue happens on all iDevices running iOS 10. Based on the mobile changelog, we start to support iOS 11+ starting 1.17.0:

iPhone 5s devices and later with iOS 11+ is required.

I see you are in a hurry to no longer support older mobile devices but the in the AppStore you are already less in a hurry. That’s a problem because people will not read the github change log before updating their app.

Since the devices are running on the older iOS, what models are you referring to? Are they able to upgrade to the latest version of iOS?

I have an iPhone 5s with iOS 10.3.1 which is supported according to the AppStore. I could update it to iOS 12.4.7, that could explain why not so many people are impacted, but I don’t want to do the update because I am afraid that I will lose some apps and my phone will be slower.

If I am not wrong the last working version for iOS 10.3 was 1.30.1, but it’s up to you to explain, the only way I know to install an app is with the AppStore.

How can you do that? If you give me a .ipa it would not be signed with my account so my iPhone will not accept it, do I miss something?

The app releases in the AppStore should work with the supported environment by default (iPhone 5s devices and later with iOS 11+ is required). Can you please confirm again if the affected users are running on the supported platforms? If yes, I would like to gather more details on the issue such as the screen shot / screen recording of the problem as well as verifying if the problem happens on all iOS users in the server.

If you need I give you a screenshot, you can see that iOS 10.3 is supported in the current mobile version (1.32.0):


I can give you a link also:
(In fact not, a message told me that I can’t post more than 2 links. That was a link to the AppStore webpage, but maybe you can find it by yourself.)

Thanks for noticing that the website mentions about supporting iOS 10.3 although it should say iOS 11. I’ll find out about getting this information updated.

1 Like

Hi there, @jean

Thank you for the detailed explanation. As mentioned by @amy.blais earlier, there is a mistake in the AppStore in which it was still showing the latest version 1.32.0 that supports iOS 10.3 or later. Our apologies on that.

Moving on to this specific statement:

The AppStore will only provide the latest version of iOS app, in this case is 1.32.0. However, users are able to download older versions through the .ipa files that are listed in our Github repository here where .ipa and .apk files of the releases are available.

If the current 1.32.0 is not working well for you and you mentioned that 1.30.1 worked well on your end previously, I would recommend uninstalling the 1.32.0 and use the following link below:

https://releases.mattermost.com/mattermost-mobile/1.30.1/287/Mattermost.ipa

Take note that this is just a workaround and there is no guarantee that it is stable in the environment that you are on. The last version that officially support earlier-than-version-11 iOS is 1.16.1.

Ultimately, do consider upgrading your iOS to the supported version to utilize the latest version of Mattermost iOS app.

I wanted to say that 1.30.1 was apparently the first not working version so 1.30.0 should be the last working version.

I can get the .ipa file but I have no clue how I can install it on my iPhone. I tried with iTunes but I don’t find any way to do this. Can you explain a little bit how can I do?

Hello, @jean

Since you mentioned that you have tried to install using iTunes but it did not go through, may I know which Mac OS version are you on?

Will it be possible for you to consider installing the .ipa using XCode or Apple Configurator 2?

I tried with XCode but that failed. I don’t think I would have better luck with Apple Configurator 2 because apps need to be signed to be installed. That’s why it can only be done with AppStore, it’s strange that you don’t know that.

The solution you propose is impracticable.

Hi, @jean

In regards to this statement:

Does that mean that you have also tried the unsigned version of the .ipa from the 1.30.0 and it failed to be installed too?

If the answer is yes, @elias is there any other way for the user to have the .ipa installed on the older iOS device?

First of all iOS 10.3 has not been supported for a while, yes the App Store says it is, but that was just an oversight which sadly happens at times.

The files found in the release page on github are intended to be distributed with EMM providers, Apple Configurator may help but unsure of the results… maybe you can find a solution on “how to install ipa files without app store” in google or something.

As for the unsigned ipa’s you could try and use some tool to change the bundle ID and then your own certificates, we do publish the unsigned builds for enterprise customers that fuse then with AppDome or Blue Cedar, if you don’t know how to do that I would strongly discurage that action.

All apps need to be signed to be able to install them on the devices.

Another option would be to signup for the beta test and attempt to install the beta version of 1.30.0 which expires in the next 18 days from today.

1 Like

I finally manage to sign the .ipa with my provisioning profile from another app which I compiled on Xcode using iOS App Signer. Then I was able to install Mattermost.ipa using Xcode.

In fact the last working version on iOS 10 is 1.28. With this version we are able to post message, but that doesn’t solve the problem of MedStudFR that he is unable to login. The login seems possible for Mattermost servers with basic configuration even new ones (at least 5.22.1), but not for others with more sophisticated configuration (obviously I don’t know exactly which one).

The biggest problem for me now is that the certificate I put in the .ipa will expire in less than 7 days (as I just have a free developer account), and if I want to continue to use Mattermost in my mobile device I will have to remake the process again and again (of course I will not do it, so it’s not a viable solution).