Hubot and mattermost adapter


#1

Hello All,

I am trying to setup hubot with the mattermost adapter but am having some issues. I run the “yo hubot” command and it asks me for the adapter, I put mattermost but then ran into the warning "hubot-help@0.2.2 requires a peer of coffee-script@^1.12.6 but none was installed. I then ran npm install -g coffee-script and coffee-script 1.12.7 was installed.

I then go back to run hubot again and get the warning “UNMET PEER DEPENDENCY coffee-script@^1.12.6” and I see the adapter is still campfire not mattermost.

I am not sure how to proceed. Does anyone have any advice?

  • Victoria

[SOLVED] Help with hubot installation
#2

Hi @vlee,

I’m going to resolve this issue and link it to the first one you opened as it’s a duplicate :slight_smile:

Please see: [SOLVED] Help with hubot installation


#3

Hi @lindy65,

Thank you for your response. But can you actually mark the other one as a duplicate? I got that issue resolved but not this one.

  • Victoria

#4

Hey @vlee,

Sorry about that, I’ve opened this one again and solved the other :slight_smile:


#5

Thanks again :slight_smile:


#6

Hello,

Just adding some more information. I received some advice to
"First run yo hubot and choose “shell” as adapter.
This wil setup the basic bot.
Then you need to install and configure a mattermost adapter, like this one:
npm install hubot-mattermost-adapter --save

After install you can then run that hubot with the mattermost adapter:
./bin/hubot --adapter mattermost-adapter"

After following the advice I get the message “EMERGENCY MATTERMOST_HOST is required”


#7

Hi @vlee,

Did you see this comment on your other post? Not sure if it’s useful?


#8

Hi @lindy65 Thank you for checking up on this post. Unfortunately, the comment is not relevant to this issue.


#9

Thanks @vlee,

Just wanted to make sure :wink:


#10

Hello,
Does anyone have any advice?
I tried running ./bin/hubot --adapter mattermost-adapter and ended up with error login call failed. If I run ./bin/hubot I get the name of my hubot. Then when I ask for adapter it is still stuck as shell.


#11

Hi @vlee,

You might want to post your question to https://github.com/loafoe/hubot-matteruser ?