How to start WebRTC?


#21

Thanks @noizzzzy.boy, I’ve asked our team + community members to take a look at this.


#22

@noizzzzy.boy A response from an engineer -

Can you try adding this value to the config.json "StunURI": "stun:stun.l.google.com:19302", without updating the Janus server or any code changes.

The ICE problem can be related to that. If the stun server from google does not work, then maybe you can try another one.

Let me know if this helps?


Webrtc audio is ok video not works
#23

@amy.blais
It was there from the very beginning.
I changed a lot of stun servers with no luck


#24

I have the exact same issue and no matter what i try it wont work.

Any updates on this?

Best regards.


#25

Hi @ggisx,

Thanks for reaching out. To give you the best help we can, could you review this web page and send us the relevant logs, config files, etc. which will help us diagnose the issue?


#26

Hi Amy,

I did not set the nat mapping in the janus cfg.

It works perfectly now thanks :slight_smile:

Best regards,

Kevin.


#27

Hi,

Could you explain nat mapping, I am trying to setup without success I have webrtc on docker and MM on host directly installed, what I am doing wrong, I got creasy now.
4.9.0-8-amd64 #1 SMP Debian 4.9.110-3+deb9u4 (2018-08-21) x86_64 GNU/Linux
i set nat to public IP on janus.cfg firewal ports for https opened wss also. I somwere full configuration described with proper config of janus in docker. Additionaly haw to use docker webrts and localy MM installed.


#28

Hi @robertl,

Unfortunately WebRTC is known to be unreliable, and I recommend exploring some other plugin options for video calls, e.g.:

Would one of these options work for you?


#29

zoom works, I will se other, but why webrtc is not working for me, do you have any idea ?


#30

Hi @robertl,

WebRTC might fail for many different reasons - one thing you could check is to try adding this value to the config.json "StunURI": "stun:stun.l.google.com:19302" , without updating the Janus server or any code changes.