We're Hiring!

Mattermost, Inc.

How to avoid Mattermost Desktop exploding in my face on each computer restart?

Summary

Each time I start my computer, Mattermost Desktop window opens full screen on my desktop computer.

Steps to reproduce

Just install and configure. Version 4.6.2 on Windows 10 20H2 (build 19042.906).
Verified on two different computers.

Expected behavior

I want to have it discretely starting minimized, I want to see it as few as possible until next message notification.

Observed behavior

Full screen opening (or at least large window opening), like flash exploding on each startup.

It seems that there is a configuration item to change for that in the bounds-info.json file in %AppData%\Mattermost folder, but in this file, the “maximized” item is already set to “false”. Obviously without any effect.

And anyway, why not in application settings, for me this is an important enough item, don’t you think so?

Regards,

Gingko

What is your “Start app on login” setting set to? Using Mattermost Desktop App — Mattermost 5.33 documentation