Mattermost, Inc.

How is the Mattermost 3.0 upgrade going?

Just want to start a thread for community members to discuss and share any issues, questions, feedback or advice from the community on the 3.0 upgrade.

How is it going?

One issue is the iOS App Store still has client version 2.1, dated March 28. Is there an ETA for the update there?

:gift: yeah…Android also… when will 3.0 Hit the Stores…?

iOS and Android apps will be in iTunes and Google Play on May 20. A note was added to the 3.0 announce, but it’s not super easy to find. Thanks for asking!

Cool, the apps have been updated. Thanks!

Went pretty smoothly! Though I went from 2.0.2 -> 3.0.2 which seems to be lucky as I missed out on some initial upgrade pains. Love the new enterprise LDAP upgrades.

Upgrade 2.2.0 -> 3.0.2

Run /platform -upgrade_db_30 without problem.
Server successfully started and there’re no errors on logs/mattermost.log.

Http code is 200 and no script error on Google Chrome when access Mattermost.
But nothing shown on Login Page.

What shoud I confirm next?

Upgrade from 2.2.0 without any hickups.
We have a team for each of our clients and a seperate team for our staff, so the multi team with 1 account is very useful.
The migration was the real pain though, spend about 10-15 min / staff member (about 30 of them) to gather all the invite links for every member.
Only issue we currently have is, if you get a notification in 1 team you get it in all teams (with the desktop app at least), when you read it in 1 team you still have to go read it in every other tab/team to actually get rid of the notification.
It’s like the notification itself propagates fine though all tabs but the notification read does not.
Its really annoying to the point where a lot of staff members only log in to other teams when they need to, and that is not progress. It’s actually causing some issues with our clients.
But I am hopeful this will be fixed soon. Can’t complain to much, if I would go I would have created a patch+PR myself.

This problem solved by bug fix of v3.0.3

Hi @DarkMukke, thanks for reporting the issue.

Here is a ticket to track the problem, it should be resolved for release 3.2.

Cheers.