Mattermost, Inc.

/gifs does not work - buttons wont click

I recently upgraded from a 4.x version to the latest 5.2. Before this everything worked relatively well, notifications were really consistent and the only complaint was gif roulette. However, since the upgrade the notifications are hit or miss and the main feature I upgraded for (/gifs) doesn’t seem to work. If I do the /gifs command it will bring up the selector but the buttons do not do anything. I can click them … but they do not react. I originally had this behind an Apache reverse proxy and I’ve been wanting to migrate to nginx so I did that. I’m not sure about notifications yet as I just completed this but the /gifs functionality is still not working. I’ve followed the mm documentation for both the SSL setup and the proxy setup itself and here’s my .conf file (on the proxy):

upstream backend {
server 10.20.5.30:8065;
keepalive 32;
}

proxy_cache_path /var/cache/nginx levels=1:2 keys_zone=mattermost_cache:10m max_size=3g inactive=120m use_temp_path=off;

server {
listen 80;
server_name chat.example.net;

   include snippets/letsencrypt.conf;
   return 301 https://$server_name$request_uri;

}

server {
listen 443 ssl http2;
server_name chat.example.net;

   ssl on;
   ssl_certificate /etc/letsencrypt/live/example.net/fullchain.pem;
   ssl_certificate_key /etc/letsencrypt/live/example.net/privkey.pem;
   ssl_trusted_certificate /etc/letsencrypt/live/example.net/chain.pem;

   ssl_session_timeout 1d;
   ssl_protocols TLSv1.2;
   ssl_ciphers 'ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-CHACHA20-POLY1305:ECDHE-RSA-CHACHA20-POLY1305:ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES256-SHA384:ECDHE-RSA-AES256-SHA384:ECDHE-ECDSA-AES128-SHA256:ECDHE-RSA-AES128-SHA256';
   ssl_prefer_server_ciphers on;
   ssl_session_cache shared:SSL:50m;

   location ~ /api/v[0-9]+/(users/)?websocket$ {
           proxy_set_header Upgrade $http_upgrade;
           proxy_set_header Connection "upgrade";
           client_max_body_size 50M;
           proxy_set_header Host $http_host;
           proxy_set_header X-Real-IP $remote_addr;
           proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
           proxy_set_header X-Forwarded-Proto $scheme;
           proxy_set_header X-Frame-Options SAMEORIGIN;
           proxy_buffers 256 16k;
           proxy_buffer_size 16k;
           client_body_timeout 60;
           send_timeout 300;
           lingering_timeout 5;
           proxy_connect_timeout 90;
           proxy_send_timeout 300;
           proxy_read_timeout 90s;
           proxy_pass http://backend;
   }

   location / {
           client_max_body_size 50M;
           proxy_set_header Connection "";
           proxy_set_header Host $http_host;
           proxy_set_header X-Real-IP $remote_addr;
           proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
           proxy_set_header X-Forwarded-Proto $scheme;
           proxy_set_header X-Frame-Options SAMEORIGIN;
           proxy_buffers 256 16k;
           proxy_buffer_size 16k;
           proxy_read_timeout 600s;
           proxy_cache mattermost_cache;
           proxy_cache_revalidate on;
           proxy_cache_min_uses 2;
           proxy_cache_use_stale timeout;
           proxy_cache_lock on;
           proxy_http_version 1.1;
           proxy_pass http://backend;
   }

}

I’ve tried disabling selinux but that doesn’t make an impact. Am I missing something here? It’s otherwise working well, but it would nice to have this functioning correctly.

Our latest server version is v5.20: https://docs.mattermost.com/administration/changelog.html#release-v5-20-feature-release.

Did you read all the important upgrade notes when updating to v5.2: https://docs.mattermost.com/administration/important-upgrade-notes.html?

Would you be able to check if the suggestions on this post might help Gfycat gifs not playing automatically after upgrade from 5.3 to 5.19?

1 Like

I didn’t see there was another update - I updated to 5.20.2 and that seems to have resolved the /gifs thing. Awaiting some incoming messages to see if the notifications behave now as well