Mattermost, Inc.

Gfycat integration is gone?

I upgraded Mattermost Server to 5.x last weekend and was pleasantly surprised that Gfycat is now supported. But after I updated the client to v4.3.1, the support was gone again. An install of v4.2.3 didn’t improve the situation. Unfortunately I don’t have an older version anymore.
With v4.0.1 it still worked.
All settings seem to be correct. EnableGifPicker is set to true.
This is what I see:
Mattermost_Gw67V4Atg4

Regards
Thomas

@VincentVegas Are existing gifs also not working or is the main issue that the gfycat picker is not available? What OS and version are you on?

Yes, the picker is missing. GIFs are shown correctly. I am running Win 10 Pro current version and tried Mattermost client v4.2.3 and v4.3.1.

Hey there @VincentVegas, the behavior appears as if gif picker is disabled, but you mentioned that it is enabled. Just to be sure, could you head to the System Console, and under Integrations > Gif (Beta), grab a screenshot of the page (you can remove the API key and secret) and paste it to this thread?

Also, which OS are you running on?

Server version is v15.6.2. Our clients are running Windows 10 PRO with latest patches.
I cannot find this subsection.
image
In config.json I find “EnableGifPicker”: true,
All I can say is that after the upgrade it worked for some hours then stopped working/showing up.
There is another strange behaviour, maybe they are connected. We cannot see the emojis we choose to react to a message. Only after hitting CTRL-SHIFT-R they are becoming visible.

I realized that most if not all of the features of v5.x are missing in the settings. I can’t find the setting for “Password Requirements” either. Had to change it in the config file.

I upgraded the server to 5.16 and then “downgraded” it to free because of an expired license. It tells me that it is Enterprise Edition but without license. Can this be a problem?

The functionality is there, only the entries in the settings are missing.

Regards
Thomas

What is your setting set for https://docs.mattermost.com/administration/config-settings.html#enable-link-previews?

Having an Enterprise Edition without a license shouldn’t cause issues.

Do you see errors in Mattermost logs?

I see masses of errors in the log:

{“level”:“error”,“ts”:1574427300.3930771,“caller”:“http/h2_bundle.go:4186”,“msg”:“http2: server: error reading preface from client 91.xx.xxx.xxx:57871: read tcp 46.xx.xxx.xxx:443->91.xx.xxx.xxx:57871: read: connection reset by peer”,“source”:“httpserver”}
{“level”:“error”,“ts”:1574428661.869899,“caller”:“http/server.go:3010”,“msg”:“http: TLS handshake error from 92.xxx.xxx.xx:59500: tls: client offered only unsupported versions: [302 301 300]”,“source”:“httpserver”}
{“level”:“error”,“ts”:1574430980.9175699,“caller”:“http/h2_bundle.go:4186”,“msg”:“http2: server: error reading preface from client 89.xxx.xxx.xx:4062: read tcp 46.xx.xxx.xxx:443->89.xxx.xxx.xx:4062: read: connection reset by peer”,“source”:“httpserver”}
{“level”:“error”,“ts”:1574430980.9181604,“caller”:“http/h2_bundle.go:4186”,“msg”:“http2: server: error reading preface from client 89.xxx.xxx.xx:3121: read tcp 46.xx.xxx.xxx:443->89.xxx.xxx.xx:3121: read: connection reset by peer”,“source”:“httpserver”}
{“level”:“error”,“ts”:1574430980.9182906,“caller”:“http/h2_bundle.go:4186”,“msg”:“http2: server: error reading preface from client 89.xxx.xxx.xx:3675: read tcp 46.xx.xxx.xxx:443->89.xxx.xxx.xx:3675: read: connection reset by peer”,“source”:“httpserver”}

are a few examples.
Other things stopped working, too.
When I invite someone to our server via eMail and he clicks the link he gets an error message that this is not an open server. I had to change settings to “open server” to be able to invite people.
When he joins the server he is not added to the team. I have to manually add him.

Something else is strange. Whenever you login via browser or client you get a “Preview Mode: Email notifications have not been configured”. You have to “Reload” via the menu to get into live mode.

Something is seriously damaged here. Any ideas what?
What shall I do? Reinstall the server?

Regards
Thomas

I updated to the latest version and now everything works again.

1 Like