We're Hiring!

Mattermost, Inc.

Gfycat gifs not playing automatically after upgrade from 5.3 to 5.19

gfycat gifs not playing automatically after upgrade from 5.3 to 5.19
they just appear as a link after server upgrade
tried it on web & a few different versions of the windows desktop app
auto play is gone on the iOS app as well
researching the issue didnt get me anywhere

thanks for your help

Are link previews enabled on your server https://docs.mattermost.com/administration/config-settings.html#enable-link-previews?

For more information, please see https://docs.mattermost.com/administration/config-settings.html#enable-gif-picker.

yes it is enabled and it was enabled before we upgraded as well.
value from the config.json file below
“EnableLinkPreviews”: true,
it is also enabled ono the account level.
Since I opened the ticket, gif auto play came back on iOS apps but not for windows desktop apps.

Hello, @iex_mattermost

May I know if the Website Link Previews is enabled in Account Settings > Display > Website Link Previews for the affected user’s account as well? Since you mentioned the following, I just wanted to be sure:

If the issue is happening to every user, can you please confirm if there has been any changes on the network level that might be blocking your session to reach out to the gfycat server?

Run the following command to confirm on this:

Ahmad-Danials-MacBook-Pro:~ ahmaddanialmohammad$ echo | telnet gfycat.com 443
Trying 99.86.176.217...
Connected to gfycat.com.
Escape character is '^]'.
Connection closed by foreign host.

Also, please check the mattermost.log for error messages related to gfycat. Thanks.