Mattermost, Inc.

First install can't access http://<serverIP>:8065 - Permissions error?

Summary

First install can’t access http://:8065 - Permissions error?

Steps to reproduce

Version 5.23.0. Not sure how to reproduce

Expected behavior

Just finished my first install of MatterMost but I cannot load a web page at http://:8065. MM is installed on Centos 7 using MySql, which is running on the same machine.

Observed behavior

With the Mattermost service started via systemctl I get http in response to running “curl http://locahhost:8065” on the server. Scanning the server with NMAP show port 8065 as closed.

When I start the server manually with “sudo -u mattermost /opt/mattermost/bin/mattermost” I receive the following possibly relevant output -

sudo -u mattermost /opt/mattermost/bin/mattermost

{“level”:“info”,“ts”:1591903262.949477,“caller”:“utils/i18n.go:83”,“msg”:“Loaded system translations”,“for locale”:“en”,“from locale”:"/opt/mattermost/i18n/en.json"}

{“level”:“info”,“ts”:1591903262.9505794,“caller”:“app/server_app_adapters.go:58”,“msg”:“Server is initializing…”}

{“level”:“info”,“ts”:1591903262.9707403,“caller”:“sqlstore/supplier.go:224”,“msg”:“Pinging SQL”,“database”:“master”}

{“level”:“error”,“ts”:1591903263.1289392,“caller”:“app/server_app_adapters.go:139”,“msg”:“Mail server connection test is failed: SendEmailNotifications is not true”}

{“level”:“error”,“ts”:1591903263.1292431,“caller”:“app/server_app_adapters.go:151”,“msg”:“Problem with file storage settings”,“error”:“TestFileConnection: api.file.test_connection.local.connection.app_error, WriteFile: api.file.write_file_locally.create_dir.app_error, directory=, err=mkdir data: permission denied”}

{“level”:“info”,“ts”:1591903263.131516,“caller”:“app/license.go:37”,“msg”:“License key from https://mattermost.com required to unlock enterprise features.”}

{“level”:“info”,“ts”:1591903263.142948,“caller”:“mlog/log.go:167”,“msg”:“Starting up plugins”}

{“level”:“error”,“ts”:1591903263.1431613,“caller”:“app/plugin.go:156”,“msg”:“Failed to start up plugins”,“error”:“mkdir ./plugins: permission denied”}

{“level”:“info”,“ts”:1591903263.1432922,“caller”:“app/server.go:255”,“msg”:“Current version is 5.23.0 (5.23.1/Tue Jun 2 02:09:53 UTC 2020/8bd90a9f6a6c5cf1c3a4f48975994eec2aa4389b/9d6d6b0a601330640d7cfe0e64be5ea6a41436d4)”,“current_version”:“5.23.0”,“build_number”:“5.23.1”,“build_date”:“Tue Jun 2 02:09:53 UTC 2020”,“build_hash”:“8bd90a9f6a6c5cf1c3a4f48975994eec2aa4389b”,“build_hash_enterprise”:“9d6d6b0a601330640d7cfe0e64be5ea6a41436d4”}

Please assist. Thanks!

Please mark as resolved / solved.

Turns out it was a firewall issue on Centos 7. Disabling the firewall completely (for testing purposes) did the trick.

Thanks for the follow-up @JonGreene just as a side-note this error:

{“level”:“error”,“ts”:1591903263.1431613,“caller”:“app/plugin.go:156”,“msg”:“Failed to start up plugins”,“error”:“mkdir ./plugins: permission denied”}

usually stems from incorrect permissions in the mattermost directory. All files and directories in there should be owned by the mattermost user and group.

Running any mattermost cli commands with sudo and without explicitly stating the mattermost user can set the permissions to the root user. Simply running with sudo -u mattermost instead fixes this. Alternatively you can also use mmctl.

Best,
Sven

1 Like