Firefox 56 and notifications


#1

Hello,

New to Mattermost 2.0. Love it so far. One thing we have noticed is that Firefox 44 has a problem with notifications. We are unable to get them to either display as a popup or play sound. In Chrome, it works just fine. I don’t know if this is a known issue or not.

If I go to Account Settings->Notifications->Desktop notification sounds, it says “Please configure notification sounds in your …” and it won’t let me set anything or click the box. There is no Edit link there either. Is that by design?

So, I tried setting the notifications up in Chrome for that account, and they work. But logging back into Firefox I get nothing.

Thanks for a fun and awesome open source project!

Jay


#2

Hi @titleistfour, can we have your help testing this fix?

Just response to the GitHub PR if it works for you?


#3

Sure thing, am testing it now. Thank you!

J


#4

Hello, I see the same issue 1,5 year later :slight_smile: I am on Linux and Firefox 57 and it is the same as in opening post.


#5

Hi @kkarpieszuk,

Thank you for your feedback,

I’ve just updated my Firefox but the latest version for me on Windows is Firefox 55.0.3. Is Firefox 57 a beta version?


#6

Firefox 57 (now 58) is the Firefox Nightly. But I have tested now in Firefox 56 (just released a ~day ago).

  • no sound notification
  • in notification settings I see “Please configure notification sounds in your …” mentioned in opening post

I am on Linux


#7

@kkarpieszuk in the original post, the discussion is about Mattermost 2.0. We’ve since released Mattermost 4.2. Can you clarify which version of the product you’re trying to use?