Mattermost, Inc.

Firefox 43, 45 Desktop Notifications Not Working

Summary

Desktop Notifications are not showing up in Firefox 43 and Firefox 45 on Centos 6. Installed Mattermost 3.5.1 to Centos 7. Websockets connecting properly and it gets sent in real time.

Steps to reproduce

  1. Log in to Mattermost
  2. Allow Notifications for site
  3. Change tabs
  4. Have someone message the channel,
  5. No notifications pop up.

Expected behavior

Since websockets are set up properly, the notifications should pop up whenever someone messages a user.

Observed behavior

  • No pop ups are shown when someone messages another user
  • Notification.permission == “granted” in the web browser console
  • Attached image as proof that websockets work fine.

Hi @qwertypuffs, are you able to receive push and email notifications as expected? Have you tried to adjust the setting for which activity triggers a desktop notification?

Hi @eric,

Yes, the desktop settings are on for all activity :

  • In Chrome 26, the ding sound notifications can be heard
  • Notification pop ups on firefox 26 - 38.
  • Firefox 43, 44, and Firefox 45ESR don’t seem to be sending notifications.

Hi @qwertypuffs, is there a reason you are using Firefox 45? I haven’t heard of any desktop notification issues on the newer versions of Firefox, it might be good try those if you have the option. In terms of other troubleshooting, have you made sure to allow notifications on the page? To do this:

  1. Right-click on Mattermost
  2. Click Page Info
  3. Select the “Permissions” tab,
  4. Ensure “Receive Notifications” is set to “Allow”