We're Hiring!

Mattermost Discussion Forums

Files uploaded prior to 6.0 not displaying when clicked on from search results

Have just upgraded to 6.0 and am noticing that when pre-6.0 files come up in search results, left-clicking them takes you to nowhere. You can hover on the button and then ‘Open in Channel’ and then view the file, or use the download button, but left-clicking on the file button itself just takes you nowhere.

Funny thing: If I do left-click the file on the channel context, it does work, and then it will work from the search results. But you can’t just open it right from search results.

Steps to reproduce
This will be hard because you’ll need to be on an instance upgraded to 6.0 from 5.x. But one could in theory post a file with searchable content to a 5.x instance, E.g. a find-me.txt with the content “Please find me”, and then upgrade to 6.0.

Expected behavior
You should be able to search for that file and left click it to bring it up within your browser window (if plain text or a basic PDF or something browser-friendly, not expecting PSD files or anything like that to be readable).

Observed behavior
You get sent to an empty gray page.

This is happening for me on both Chrome and Firefox.

@smallcitylibrary Do you see any errors in Mattermost logs when this happens?

@hmhealey Would you know who is most familiar with taking a look at this?

I do see some concurrent errors in mattermost.log from just now when I tried to open two different text files from search that had not before been opened in 6.0:

{“timestamp”:“2021-10-14 16:11:50.579 Z”,“level”:“info”,“msg”:“error [2021-10-14 16:11:50.579 Z] Unable to clean up the sessions caller=“mlog/mlog.go:228” error=“no update allowed from focalboard, update it using mattermost”\n”,“caller”:“io/io.go:425”,“plugin_id”:“focalboard”,“source”:“plugin_stdout”}
{“timestamp”:“2021-10-14 16:12:34.086 Z”,“level”:“error”,“msg”:“http2: server connection error from 192.168.0.145:49222: connection error: PROTOCOL_ERROR”,“caller”:“log/log.go:184”,“source”:“httpserver”}
{“timestamp”:“2021-10-14 16:12:34.086 Z”,“level”:“error”,“msg”:“http2: server connection error from 192.168.0.145:49222: connection error: PROTOCOL_ERROR”,“caller”:“log/log.go:184”,“source”:“httpserver”}

Our instance is on https - a Let’s Encrypt certificate still good for another two months.

(That internal IP address isn’t mine, though, so it could be unrelated. Also there were other instances of the “unable to clean up the sessions caller” error from overnight, when I don’t think anyone was working.)

@streamer45 @mgdelacroix Please take a look if the logs here are helpful.

I believe I’m able to reproduce this, so I opened a ticket: [MM-39393] Files uploaded prior to 6.0 not displaying when clicked on from search results - Mattermost

Sweet! Thanks very much!