We're Hiring!

Mattermost, Inc.

Fails after upgrade

Summary

After upgrade, can’t start Mattermost

Steps to reproduce

I started with a DigitalOcean Marketplace installation of Mattermost a few weeks. Got a notice today that it is way out of date. Went carefully through the upgrade instructions. After finishing that, tried to restart Mattermost. It fails. Log message says:
Error: listen tcp :443: bind: address already in use

Expected behavior

Mattermost should start successfully.

Observed behavior

Error: listen tcp :443: bind: address already in use

[Solved] The upgrade changed config.json in ways that were incompatible with using Nginx as a proxy. I changed these variables to the values shown and it started working again.

"ListenAddress": ":8065"
"UseLetsEncrypt": false
"Forward80To443": false

Hello, @gauss256

If you don’t mind, can you please share the following information here as I want to understand the problem a little bit better?

  • The documentation you used to install and upgrade
  • Original Mattermost Server version and the version that you upgraded to
  • The values of ListenAddress, UseLetsEncrypt, and Forward80to443 that the upgrade changed before you fixed the value

If you followed the upgrade instructions properly and run into this issue, something is not right and I would like to know what it is.