Mattermost, Inc.

Error using WebRTC feature

Hi,
I’m trying to test the WebRTC feature, but no luck until now

Here my setup

  1. mattermost 3.7.3
  2. janus server 0.2.3 (no docker image, I setup my own server)

I configure mattermost, enabled WebRTC integration and started a call, I receive the following error

mattermost log:

[2017/04/03 15:37:12 CEST] [EROR] /api/v3/webrtc/token:getWebrtcToken code=500 rid=qw6ybguii7b5dfqtbae47w7a1y uid=a1ci7kinjbf15jgbucb9yfuo8r ip=xx.yy.zz.kk We encountered an error trying to register the WebRTC Token [details: ]

janus log:

Mon Apr 3 15:37:12 2017] {“admin_secret”:“XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX”,“janus”:“add_token”,“token”:“cmR3aTdqc3pqdGdxcGpucjg1dGRxbnVmOXI=”,“transaction”:“w7b79gp3tjd5ffk7u4jbrqs3wa”}
[Mon Apr 3 15:37:12 2017] Forwarding request to the core (0x7f9eec0008c0)
[Mon Apr 3 15:37:12 2017] Got a Janus API request from janus.transport.http (0x7f9eec0008c0)
[Mon Apr 3 15:37:12 2017] Transport task pool, serving request
[Mon Apr 3 15:37:12 2017] [w7b79gp3tjd5ffk7u4jbrqs3wa] Returning Janus API error 457 (Unhandled request ‘add_token’ at this path)
[Mon Apr 3 15:37:12 2017] Got a Janus API response to send (0x7f9eec0008c0)
[Mon Apr 3 15:37:12 2017] [transports/janus_http.c:janus_http_request_completed:1749] Request completed, freeing data

I tried to test the janus server alone using the html directory provided inside janus setup and the videocall was ok, both video and audio were working

I thonk that the line in janus log (Unhandled request ‘add_token’ at this path) indicates that my janus server is not able to understand mattermost request, so maybe there is a version mismatch and I can’t use latest version of both services?

has anyone encountered a smilar issue?

best regards

Hi @andreacappelli,

Thanks for your question!

There is this thread where you might find some help for your issue. If not, please let us know and we’ll try to assist further.

Thanks!