We're Hiring!

Mattermost, Inc.

EnableOnlyAdminIntegrations not working since last update

Since our last mattermost update The option to allow non-admins to create integrations is gone.

I did read in the documentation that since 4.8 the option has been removed from config.json and gitlab.rb (I’m using the omnibus package) and is now directly configured via system console.

No matter what I try I cannot get it working. The option is completly missing from the system console.

Was this feature moved to EE only ? I’m a bit confused.

I’m currently running Mattermost Version: 5.2.1 - Team Edition

Thanks in advance

Hi @samzorio,

There should be a section called “Integrations” in the System Console, can you help confirm if you see this option?

Hi,

I do not see it.

Hi @samzorio,

  1. Do you see “Integrations” option when you click the Main Menu?
  2. What version did you upgrade from?
  3. Can you help with any additional relevant information about your environment from this page: https://docs.mattermost.com/process/support.html#general-questions-for-any-issues?
  1. I do see integrations in the system console but im missing the option to allow non admins to create integration.
  • Basicly other than admins no one sees the integration in the main menu
  1. If i remember i upgraded from 4.5 to 4.8 to Mattermost Version: 5.2.1 - Team Edition

  2. I’m using mysql driver and not pgsql, I tried passing the env variable ‘MM_SERVICESETTINGS_ENABLEONLYADMININTEGRATION’ => ‘false’,

Hi @samzorio, I believe you’re correct that only admins can access Integrations (either Team Admins or System Admins).

Is this a change that was introduced in 5.x team edition because I had the option to open integration creations to all users before with that option that i’m missing from system console.

Hi @samzorio, after taking another look it seems you’ll need to enable it from System Console > Integrations > Custom Integrations. More information is here: https://docs.mattermost.com/developer/webhooks-incoming.html#simple-incoming-webhook.

Hopefully this helps!

hi @amy.blais thats what i’m saying the option is missing from System Console > Integrations > Custom Integrations .

i’m including a screenshot https://imgur.com/a/RGHcXMa

Hi @samzorio,

What I meant is that as soon as Webhooks are enabled in the Custom Integrations section, then all users should be able to have access to Integrations. But it looks like some of your settings are configured through an environment variable, so modifying it in the System Console is disabled. Can you help try using the env variable setting to enable Incoming Webhooks and Outgoing Webhooks?

Hi @amy.blais As you can see in the screenshot webhooks are enabled in custom integrations. And still theres no option to allow non-admins to create integrations.

@samzorio,

I checked with our team and it looks like the setting was accidentally removed in Team Edition with v5.0 introduction of the new permissions schemes for Enterprise Edition. It was added back in v5.3 for Team Edition (bug ticket: https://mattermost.atlassian.net/browse/MM-11920). So the solution would be to upgrade to v5.3 or later version.