Mattermost, Inc.

Email notification settings

We just started using Mattermost with Gitlab and have been loving it so far. One thing that’s come up is when the Mattermost chat window isn’t in the foreground it emails you immediately. What happens is I’ll usually see the desktop notification and then go to click on it to bring open the chat window, but by that time I’ve already gotten 2 emails to go with the desktop notifications that I’ve gotten too, so it gets a little noisy at times.

Is there a setting somewhere where you can adjust the time it waits before it sends an email out? Say a minute or two?

Were also using this as an app "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --app=http://mattermostserver/channel so it opens in it’s own app window. Not sure if this makes a difference or not.

Any help or ideas would be appreciated!

Just a follow up. I just disabled email notifications for the time being as a work around for because I’m in there enough that I can just catch up when I get to the messages. Not sure what the best answer is going forward but I’m happy with this.

im using linux, and yes the email notification is annoying , because when i hear the chrome notifications, and then my mobile get the email too, what is the point? :disappointed: maybe can delaying the email notification further for 5 or 10 minutes??

Hi @auzty, we have a ticket tracking this issue here: https://mattermost.atlassian.net/browse/PLT-2451