Mattermost, Inc.

Direct Messag Refresh issue

Hi all,

I’m new to Mattermost, and I allready like the software.
I however seem to have run into a bit of a problem. So let me try to explain.

I have medium sized environment, about 1500 named users, of which we want about 500 named users to be able to access Mattermost as a quick chat platform.
The server is installed on a UBUNTU 14.04.03 LTS OS, 2CPU, 4Gig RAM… Should do the trick, installed using the provided manual, al thee services on 1 machine.
I have created about 5 test users, and 1 Team. Alle 5 users are member of that team.
My firewall is doing the SSL offloading, and that works fine. A user connects to an url via https. Certificates are all OK.
The firewall makes a connection to the server in the DMZ, on port 80. Works like a charm. Informtation is exchanged and so on.

I created the required firewall rules/vips/services to be able to access the machine from outside the companies network.
I created the required firewall rules/vips/services to be able to acces the machine from inside the companies netwerk.

User1 is connected from outside the network, and sents a direct message to User2 (also outside the network). However, User2 does not see this message until he writes a message himself, or refreshes the page.
User2 sents a message back to User1, but User1 does not recieve this message, until he writes a message himself or refreshes the page.

If I run the same test on the internal VIP in the firewall. It all runs OK.
When User1 is inside the network, and User2 is outside the network, no messages are being seen until a refresh.

Does anybody now how to resolve this? Or has anybody ever seen a similair problem?

If additional information is required, just let me know. For now it’s kind of a show-stopper to implement the software in prodcution, let alone continue to upgrade to the commercial version with LDAP support.

Thanks for your time,

Best regards,

Rob

I don’t know about you, but for some reason, you can bash your head for 2 days on a problem. Finally decide to ask for help and insights. And the moment you hit “sent”, you find the solution to your problem.

I’m still running some more tests, but it seems to have been the firewall which caused the problems. The firewall is running host-headers to share 1 IP with serveral URL’s. And that is where it was failing.
I managed to free up an IP for mattermost, and for now it seems to be updating the direct messages as expected.
I will run some more testing to see if it really fixed the problem.

1 Like

This might be a situation where https is properly configured, but wss is not–which would let you see the UI, but the real time functionality wouldn’t work until wss is working.

For anyone else who comes across the thread, if you see a a blue bar error message mentioning “Mattermost unreachable” or WebSockets, please Google the text and you should hopefully find help?

hehe who doesn’t know that - it’s also the reason why rubber ducking is so effective,-)