Mattermost, Inc.

Desktop Client/application Notififcations not working. Need to refresh or switch channels to view new messages

Hi,

I am not getting real time perfomance in mattermost. Details of my mattermost setup is mentioned below :

  • I am using Mattermost 3.10.0.
  • Installed this on Docker and deployed on AWS ECS cluster.
  • Having 2 Mattermost instances behind application load balancer
  • using AWS managed MySql service.
  • The site is accessed via url created Route53.
  • Mobile application is working fine.

Here are the issues :

  • Not getting notification sometime.
  • When chatting with someone/channel, need to reload or switch channel to get new messages.
  • Mattermost stop giving any response suddenly, need to restart the service.

Hello @kverma,

which operating system (with version) are you using the mattermost desktop application with? also, what version of the Desktop app are you using?

Thanks,

Sousapro

@Sousapro hey, my team is having windows7/8, and the version of Desktop application is 3.7.0.
I tried this using google chrome, but getting the same issue. Can not see new messages untill I switch channel or reload.

Any suggestions/updates ???

They are very sporadic, sometimes it works, sometimes it does not. Of course this mostly happens when something important happens. It is really hard to not be able to depend on notifications. We are running Mattermost (V4,0) docker installation

yes…exactly @BobTB… if it continues, we can not use it for team communication as each and every messages are important and we have to go inform that person personally or via other messaging app that i have sent a message on mattermost, please refresh!!!
Need solution for this ASAP otherwise have to switch to other options.

@kverma,

I’m looking into this issue but I personally have not seen anything like this with an AWS instance of Mattermost running. After talking with some of the devs, I’m kind of leaning towards a Websocket issue with your load balancing proxy (i’m assuming you’re using NGINX for that but correct me if I’m wrong). Are you getting any errors in your mattermost.log and NGINX logs?

https://docs.mattermost.com/install/troubleshooting.html#please-check-connection-mattermost-unreachable-if-issue-persists-ask-administrator-to-check-websocket-port

@kverma and @BobTB,

I just did some additional discussion and I need to verify if you are using Mattermost Team Edition or the Paid Mattermost Enterprise edition. if you are not using Enterprise Edition (with a valid license), you will be unable to enable High Availability / Clustering mode. without HA enabled, you will definitely experience that kind of notification weirdness with multiple MM instances talking to the same database while you’re waiting for the other server to catch up. if you’re on team edition, my suggestion would be to drop the second instance and remove mention of it from your NGINX configuration. This will almost certainly resolve your issue.

Sousapro.