Mattermost, Inc.

Desktop App: Marking users as away not working

Hi,

according to the forum users should be marked as away when they switch the application or when they are away from the computer. But in our installation all users are online as long as the the windows app is running even if they lock their computer. Is this a “feature” of the windows app or what could be the reason that automatic away is not working for us?

Thanks
Achim

Thanks @vornbera for the report!

Which

  1. Mattermost server version (from Three-Dot Main Menu --> About Mattermost dialog)
  2. Mattermost desktop app version (from Help --> Version)

are you using? That helps us troubleshoot potential issues.

Hi Jason,

the latest versions

Server: 3.4.0
Windows App: 3.4.1

Thanks
Achim

Thanks @vornbera, very helpful.

I was unable to reproduce it so far - two more questions that can help with investigation:

  1. Does this behaviour reproduce on the web app (on the browser), or is it only happening on the desktop app?
  2. If another user is away for more than 5 minutes, would their status change if you switch a channel or refresh the client? If it does, it might be related to WebSocket connections.

Status is changing only from online to offline with the start and stop of the app, no automatic away so far. But sometimes users are offline for a few seconds. Could this be a problem with our network configuration, especially how we configured our firewall for internet access?

You mentioned the WebSocket connections, is there anything I could check?

Thanks
Achim

Thanks @vornbera,

were you able to reproduce it on the browser, or is it only happening on the desktop app?

Same problem in the browser using google chrome

I see, it appears it could be a network connection issue as you mentioned.

Would you be able to see if there are any red entries in the Browser Developer Tools:

  • on Chrome, press CTRL+SHIFT+I
  • choose the “Network” tab and use the Mattermost service. Observe if there are any entries marked in red

It could be that the Webocket connection is being interrupted by the firewall. This happened to a community member before setting up SSL.