Mattermost, Inc.

Deployment configuration overwritten

Summary

Windows desktop app 4.3.1
Deployment default configuration is being overwritten.

Steps to reproduce

Follow the deployment documentation: https://docs.mattermost.com/deployment/desktop-app-deployment.html

  • Install the application
  • Create a default config file
  • Open the application

Expected behavior

The Mattermost desktop application opens using the configuration file provided

Observed behavior

The Mattermost files are being created with the first execution of the application, rather than with the installation, so the configuration file provided is overwritten with a default one.

Additional info

It seems that this doc is outdated, it also indicates that the silent flag is --silent instead of /S (version 4.3.1)
It would be nice to avoid the creation of the configuration file if it already exists. This would solve this issue and also allow us to keep the user configuration during the upgrade of a previous version.
This issue happens with both, .exe and .msi installer.

Hello, @epuentes

I have shared your observation in regards to the desktop app deployment to the apps team and I would recommend you to join the Desktop App discussion to keep yourself on top of any updates from them. Feel free to share any additional thoughts that you have there. Thanks.

Hello @ahmaddanial,

Thanks for your help!

1 Like

Hi, @epuentes

Got the update from the team on this.

We added a configuration validator which in case it fails gets overridden by the defaults. There are two things that can fail:

  • Schema:. you can see it in github.
  • Since we added URL validation, that also might fail on the teams configuration.

Since that is specific to user configuration, may I know if we can get access to your config.json file to see if it’s covered by one of the two options above or if it is indeed a bug because it’s not covered by the above options? Please remove any sensitive information such as password from it before sharing it here. Else, you can do it directly to the thread I made here. Thanks.

Hi @ahmaddanial,

Thanks for your help, I just wrote a message with my configuration in the mentioned thread.

1 Like