Mattermost, Inc.

DefaultServerList GPO Failing

Server Version: 5.13.1
Desktop Version: 4.3.0, Windows 10 Professional

Summary

Applying the DefaultServerList GPO does not work for most users, except the Domain Administrator.

Steps to reproduce

Apply DefaultServerList GPO, verify that it was applied successfully using gpresult, and open Mattermost, it will prompt you to add a server, and will not list any servers by default.

Expected behavior

Automatically prompt user to login to the first server on the list

Hi All,

I’ve deployed Mattermost to our PCs via Group Policy. I’ve also configured three settings via GPO,

  1. DefaultServerList with only one entry
  2. EnableAutoUpdater = False
  3. EnableServerManagement = False

The deployment was successful, however, when opening Mattermost (logged in as a regular user), it prompts the user to type in a server name, which is the opposite of #3 above. When logging in as the domain administrator, everything works as expected (1, 2, and 3 are applied).

I have verified that the policy IS being applied via gpresult and rsop to both accounts (as it is a Computer Policy). I cannot verify that it is properly set in the registry, as our regular user accounts do not have permission to modify the registry, therefore, I cannot open it.

Any suggestions?

EnableServerManagement = False

This should be true.

@JtheBAB, I think based on reading the description, that enableServerManagement = True will allow users to add their own servers. Is the description wrong on the GPO by any chance?

Also, it’s working as expected currently with enableServerManagement = false, but only with domain administrators.

Yeah your right. Sorry.

Where do you see the values that you set with the domain admin in the registry?

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mattermost\

„Resolved“ by https://community.mattermost.com/core/pl/xrdpgfbcki8a8e5p9jz35oznch

Problem is that the used Package can’t access the registry when the registry is blocked by GPO