Matttermost, Inc.

Database schema version 5.10.0 is no longer supported. This Mattermost server supports automatic upgrades from schema version 3.0.0

Summary

Migration from mattermost/mattermost-prod-app:latest docker to mattermost/mattermost-team-edition:5.9.0 docker causes database schema version error.

Steps to reproduce

Install mattermost/mattermost-team-edition:5.9.0 docker image and connect it to database initially used by mattermost/mattermost-prod-app which was using Team Edition at the time of installment. The entire setup runs in kubernetes cluster.

Expected behavior

I could not find proper explanation on how to migrate the database to be used with the new mattermost-team-edition. Googling did not help. The closest thing I found was this: https://docs.mattermost.com/administration/legacy-upgrade.html

Observed behavior

We were previously running mattermost/mattermost-prod-app:latest docker image for our mattermost installation. However, This repo will be deprecated in Mattermost 6.0 so we want to move on to mattermost-team-edition. Upon installation of the new team-edition connected to the old database I get the error “Database schema version 5.10.0 is no longer supported. This Mattermost server supports automatic upgrades from schema version 3.0.0”

@cpanato / @pichouk Are you familiar with this?

The Docker image didn’t changed. What was the version you used on your previous Mattermost deployment. I think you used Mattermost 5.10 of the image mattermost/mattermost-prod-app and the issue is that you try to downgrade to Mattermost 5.9.

Try to use mattermost/mattermost-team-edition:5.10.0 or mattermost/mattermost-team-edition:5.11.0.

Ok, thank you. I thought I was using the latest tag for the mattermost-team-edition, but you were right. The installation was of mattermost 5.9.0 version…